Weird problem with my car audio unit

KaiserD2 Newbie
My car is a 2016 Ford Focus and the unit is the original one. It has worked fine with my phone and with my ipod classic which is the key issue. The radio and phone are still working fine but something bizarre has happened with the ipod--and the problem isn't the ipod.
To play the ipod you hit a media button on the unit. It gives you about five options, including usb1 and usb2. I always have the ipod on usb1. If it doesn't go on automatically, I just have to use the up and down buttons to reach the listing for usb1 and select it. Very simple.
Suddenly, however, the menu entries for usb1 and usb2 are dark and you can't select them. The cursor won't go there. The problem isn't the cable either--I tried a different one. I don't think its the USB port either because I tried usb2--no luck--and how could both of the ports fail at once? I tried a reset of the unit and that didn't help either.
Any ideas? Thanks in advance.

KaiserD2 Newbie
Well, this stumped everyone, apparently, but I eventually figured it out myself.

What was so confusing was that on its own the ipod was working just fine. However, just this morning, when I hooked it up to my desktop to load something, the desktop didn't recognize it. That is usually the cable but a second cable didn't help. Finally it occurred to me to reset the ipod. Presto! Both the desktop and then the car stereo recognized it. Apparently the software that announces it to a device had gotten corrupted. Now I can cancel my February Geek squad appointment at Best Buy!


audiobaun Veteran
5,000+ posts
10+ year member
Thanks for sharing the issue and sharing how to possibly fix any future issues for others

About this thread

Who Replied
Last reply date
Last reply from

Latest threads