Terrible problem


Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
So I have an alpine sa60m amplifier new and a new Rockford fosgate p3d412 wired to 2 ohms to match the amplifier both having 600 rms 2 ohms ratings, this said, maybe the sub is just weak, but for 200$ I expected to feel the sub and at best you only hear it and the occasional rattle and then it pops, so I run back to turn down the gain a little and when its " set properly " its non-existent. Extremely irritated. Been following other threads for a week with no positive result. I see videos of the sub review on YouTube and the p3 is shacking the whole car sometimes, but mine is a waste of good materials then. Someone please tell me what your insight might be and one the problem might be. I'm in a 2008 Mazda 3, it's grounded well, powered well, 2 guage wire, the amp never shuts off, the sub just pops and I want to push it way harder but can't. The amp does have a "preamp" set of RCA's, will buying a preamp fix my problem or not ? Anything helps
 

shredder2

Enthusiast
Nov 19, 2017
2,512
399
Az
So I have an alpine sa60m amplifier new and a new Rockford fosgate p3d412 wired to 2 ohms to match the amplifier both having 600 rms 2 ohms ratings, this said, maybe the sub is just weak, but for 200$ I expected to feel the sub and at best you only hear it and the occasional rattle and then it pops, so I run back to turn down the gain a little and when its " set properly " its non-existent. Extremely irritated. Been following other threads for a week with no positive result. I see videos of the sub review on YouTube and the p3 is shacking the whole car sometimes, but mine is a waste of good materials then. Someone please tell me what your insight might be and one the problem might be. I'm in a 2008 Mazda 3, it's grounded well, powered well, 2 guage wire, the amp never shuts off, the sub just pops and I want to push it way harder but can't. The amp does have a "preamp" set of RCA's, will buying a preamp fix my problem or not ? Anything helps
P3-12d4 enclosed how?
sealed box it sounds like
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
Get that thing ported and tuned correctly. Make sure your wiring is tight and grounded properly.
Okay I just went threw and redid the wiring and made sure my jumpers were tight with the wires to the amp, how would I go about ported a box correctly ??
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
Ordering a 1.83 sound ordannance box off crutchfield to make sure I get it rigbt, the box I have I think is sealed and only 1 cubic feet, do you think going from sealed to ported and adding .83cubic feet will make a big enough difference it'll be noticeable ?
 

shredder2

Enthusiast
Nov 19, 2017
2,512
399
Az
Ordering a 1.83 sound ordannance box off crutchfield to make sure I get it rigbt, the box I have I think is sealed and only 1 cubic feet, do you think going from sealed to ported and adding .83cubic feet will make a big enough difference it'll be noticeable ?
It might suffice for added output in the 40-50hz range and make you happy, which one did you get?
S/O prefabs are just that... prefabs with higher tuning and mass produced, building a custom design for that P3-12 eventually should really make a difference. That S/O enclosure is probably nowhere near this size...

1.65ft3 net after displacements... it's for a similar sub and made a big difference over sealed.
 
  • Like
Reactions: Bobbytwonames
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
It might suffice for added output in the 40-50hz range and make you happy, which one did you get?
S/O prefabs are just that... prefabs with higher tuning and mass produced, building a custom design for that P3-12 eventually should really make a difference. That S/O enclosure is probably nowhere near this size...

1.65ft3 net after displacements... it's for a similar sub and made a big difference over sealed.
How much would this cost to build And what materials would I use ? Also how do you get it to "tune" to a certain hz
 

shredder2

Enthusiast
Nov 19, 2017
2,512
399
Az
How much would this cost to build And what materials would I use ? Also how do you get it to "tune" to a certain hz
Port area in a certain volume tunes an enclosure, It's best to learn to model any enclosure on your power but with only a 600rms amp @ 2 ohm in a sealed enclosure... I'd expect noticeable gains even with a prefab... just not great low-lows.

omg...
I thought so... lol... yep... that thing sells and might bang (or maybe not?) but not dig well. The cost to DIY a single 12 enclosure is $40-$50 in materials, as long as you have basic tools (jigsaw, screwgun)... any big box home improvement store can usually make the larger basic cuts, so assembly and cutting the hole shouldn't be too hard.
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
Ugh well I'll write my finding once I get the s/o hopefully it's enough that I'm not still terribly disappointed as I have been with the output up to this point lol
 
  • Like
Reactions: shredder2

ThxOne

AudioFreak
Jun 8, 2018
1,794
317
Saint Marys, GA
I have the same model sub only in the 10" version... it slams pretty good on a Prime 1200-1D @ 2ohms. Ported Pre-Fab enclosure... for now. Your 12" should be moving some air for sure. Something ain't stirring the Cool-Aid.

It sounds silly but pull the sub out of the box and triple check that the wiring is like this pic.
 

Attachments

OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
I have the same model sub only in the 10" version... it slams pretty good on a Prime 1200-1D @ 2ohms. Ported Pre-Fab enclosure... for now. Your 12" should be moving some air for sure. Something ain't stirring the Cool-Aid.
Wouldn't your 1200 be way to strong for a p 10?
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
Well my amp is on 2 ohms with rms 600 and barely any gain maxes it out and makes the sub pop, am I doing something wrong or is your sub taking way more power than mine
 

Bobbytwonames

Professional Fisherman 🎣
Aug 28, 2018
1,808
-193
Well my amp is on 2 ohms with rms 600 and barely any gain maxes it out and makes the sub pop, am I doing something wrong or is your sub taking way more power than mine
Is your bass boost off? It just sounds like a tuning thing. Crossover should be set at about 80hz.
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
Yes starting with boost off I tune gain first till I hear distortion, but I never get to hear distortion, it just starts popping till I ease it off
 
OP
B

Burkie81

CarAudio.com Enthusiast
Apr 6, 2020
24
1
Oneida TN
The amp has pre amp receptors on it, would pre amp shrink the signal to allow my sub to not clip when given more of it OR does pre amp make a signal larger, which would be the opposite of what I need
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Latest posts

Trending topics