Speakers and subs not working help

Pookster

CarAudio.com Newbie
I installed 2 12s and an amp in my 1998 ford ranger, everything is soldered and hooked up, tested power and ground they are good and the amp turns on but subs make no noise. As I'm trying to figure this out standing outside the truck while I had music playing the music stopped out of nowhere. My head unit is a JVC KW-M788BH I installed a couple months ago in replacement of a cheap amazon radio i bought that was junk after like a month, the JVC still works and screen is like nothing happened everything works but no sound.

that was yesterday today i went out to the truck, the radio worked for like 20 seconds playing a random radio station and then it stopped and made a clicking sound like 5 times it kind of sounded like a NRG quick release lol. I was running the battery for maybe 10 minutes total but like on off for maybe half an hour and all of a sudden the battery died. so something is obviously not right here, I disconnected the battery and have it on the charger right now.

everything that is installed is all soldered and hooked up like it should be working fine but is not
 
that was yesterday today i went out to the truck, the radio worked for like 20 seconds playing a random radio station and then it stopped and made a clicking sound like 5 times it kind of sounded like a NRG quick release lo
When your battery runs low while playing music, the radio will make odd sounds. Charge the battery and when installed, play the music with the charger going at the same time. See if your radio issues continue while you have a good power source.
 
Sorry I couldn’t remember my login after testing it ended up being a bad alternator. Put a new one in today and subs are bumping idk how to delete the po
When your battery runs low while playing music, the radio will make odd sounds. Charge the battery and when installed, play the music with the charger going at the same time. See if your radio issues continue while you have a good power source.
got it fixed today needed a new alternator thank you though
 
Activity
No one is currently typing a reply...

Similar threads

I installed 2 12s and an amp in my 1998 ford ranger, everything is soldered and hooked up, tested power and ground they are good and the amp turns...
0
182
Try placing the subs in the front seat, to see if the issue persists. Just for diagnostic purposes. It may be wiring, but the distortion may be...
2
1K
Sounds like you shorted the other channel so check you connections. Don't ask just look. Will solve your problem Every time. If you ever short out...
9
2K
My guess is the dash speakers are more sensitive plus they're getting a boost from being closer. Maybe a cheap L-Pad to dial the dash speakers down.
3
57
All things being equal in comparing speakers on the same amplification, the difference in overall volume will be slightly less with a same...
9
316

About this thread

Pookster

CarAudio.com Newbie
Thread starter
Pookster
Joined
Location
america
Start date
Participants
Who Replied
Replies
6
Views
365
Last reply date
Last reply from
audiobaun
20240720_091846.jpg

Bobbytwonames

    Jul 20, 2024
  • 0
  • 0
Screenshot_20240720_092450_Gallery.jpg

Bobbytwonames

    Jul 20, 2024
  • 0
  • 0

New threads

Top