Help with 1996 Crown Vic wiring


DIYing but kinda dying

CarAudio.com Newbie
Jul 24, 2019
2
0
Alberta, Canada
I'm putting an aftermarket head unit in a 1996 Crown Victoria--or at least trying to. I cannot find the proper adapter harness to connect the aftermarket radio to factory wiring.
The stock radio has 2 plugs going in the back. 1 is the standard gray 8-pin Ford that's used in numerous models and is easy to find. The other is this weird little 16 pin plug that only uses 8 of the pins. Images attached.
I've taken this car into numerous car audio places, asked Crutchfield, and no one seems to know where to find a harness that fits this thing. I was recommended numerous Metra harnesses, but nothing has fit. Note the placement of the receivers for pins connecting from the stereo/adapter.
Car info: 1996 Crown Vic, base model, no premium sound system, no factory amplifier.
Any help or recommendations is appreciated.
 

Attachments

Ripkon

CarAudio.com Well Known
Apr 11, 2019
152
25
Virginia
My Vic is 05 and had a large plug then a smaller plug. I only need to utilize the larger plug. This could be your problem here. You only need to connect the 1 plug
 
OP
DIYing but kinda dying

DIYing but kinda dying

CarAudio.com Newbie
Jul 24, 2019
2
0
Alberta, Canada
My Vic is 05 and had a large plug then a smaller plug. I only need to utilize the larger plug. This could be your problem here. You only need to connect the 1 plug
I tried that method, but the 8 pin gray only supplies power to the head unit. I could load CDs, connect Bluetooth, control the dimmer, and so on, but without the 2nd plug, I got no sound.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Latest posts

Trending topics

Latest classifieds