amp wont work

borisshnitkin
10+ year member

Member
80
0
nj
i just installed my 2 type r's in a new box and for some reason the amp doesnt want to work. the light wont even turn on. i first thought it might be the protection mode but it is also not on. i work in circuit city and the guys there have no idea whats wrong. one said that there might be a problem with the wires. another said that it could be the amp. i started to get this problem just when i first got this new box. maybe i wired the subs wrong i dont know. the subs are dual voice coils. and the amp is a us accostics 800f. here are the specs for the amp......

RMS, per channel @ 4 Ohms @ 12.9v input 300Wx2CH

RMS, per channel @ 2 Ohms @12.9v input 400Wx2CH

RMS, Bridged Mono @ 4 Ohms @ 12.9v input 800Wx1CH

how should i wire the subs in the box with this setup to get the max power.

i also installed bass blockers for my speakers cause they are the factory ones, could the problem be that the wiring be short in the back (the remote wire) i dont know guys, im so pissed off right now. please help.

maybe there is a short in the wire's,who know's.

give me some things i should try to get this amp to work.

also when it starts to work, around 10 min or so the amp would stop working, not even go into protection mode or anything. please help!!!!!!!!!!!

 

allyourblood
10+ year member

kill the fakes
double check all of your wires, including the power, ground and remote. triple check them, that they're secure, and not touching each other at any point. (do this at the HU, too). check your fuses too, both on the power wire, and in your amp.

abe m.

 
OP
B

borisshnitkin
10+ year member

Member
80
0
nj
i just went to test if it was getting power with a meter and then all of a sudden i see the power ligth turn on. im wondering why it would work if i try and test the power wire and the remote wire with a meter and then all of a sudden i see that the power light turns on.

what does that mean and how do i fix this problem.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

You could run that sub on a 4 channel amp and have 2 channels left for amping front speakers. I just put a small system in my brothers car with a single low powered sub bridged on 2 channels and...
16
2K
Your amp 12v+ is usually a thick wire, same thickness as your ground wire. The remote input is a thin wire that is usually connected to a wire coming out back side of your aftermarket head unit...
4
1K
So gain is set at 0.45v. Try connecting your phone to this amplifier via 3.5mm to RCA via patch cable, see if you have better output.
3
866
The thing is that you are describing a "signal sense" feature, that is only used when installing an LOC to an OEM radio. It is to avoid hunting for a keyed fuse to run the remote turn on. You have...
3
817

About this thread

borisshnitkin

10+ year member
Member
Thread starter
borisshnitkin
Joined
Location
nj
Start date
Participants
Who Replied
Replies
2
Views
695
Last reply date
Last reply from
borisshnitkin
IMG_0350.jpeg

DEW123

    Feb 23, 2024
  • 0
  • 0
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top