Jump to content


Sign in to follow this  
Dt87

Powered subwoofer install

Recommended Posts

I currently have 2 pairs of 6x9s in the front and rear doors of my truck that I have an amp running. Sounds great but here recently I've decided to throw a subwoofer into the mix, and Im hoping you guys can help me out with what's going on. So I'm installing the PT-250 10" kicker powered subwoofer with built in amplifier. It doesn't have your regular rca inputs that you would normally see on most of your after market amplifiers. It uses a single wire harness that consists of your normal ground, power (W/Inline fuse already prepped basically), remote turn on lead, and a pair of speaker leads that are color coded for front L&R. The manual says to just tap into the head units speaker leads and you will get your signal. It also has a toggle switch that let's you choose ahigh level or  low level. I'm thinking ok, sounds simple and the install will be a breeze. So I ran all my wjres, gave it a clean install, but when I turn my stereo on, the subwoofer works just fine, but for some reason my door speakers will barley turn up as if they're just not getting any power. Almost as if the volume is just way down on them. My setup for the amp that is running them is your normal low level input for better performance. On the powered kicker it has a high level or low level option as I said a second ago and I chose low level because it all needs to match. You can't have a low level and high level running at the same time from what I understand.. So on the powered sub, I made sure it was on low level and I'm still getting the same results. Even after jacking with all the toggles on the sub to try and trouble shoot what could be wrong its just the same thing. A loud sub with base and barely any volume coming from the door speakers. I also tried doing an outline converter which I know is kinda backwards when trying to convert over to low level input from a sub to the head unit instead of the other way around, and it didn't work either.   Any idea what's causing this or what might be going on? Any insite or info would be greatly appreciated! Thank you! 

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×