Jump to content


Solo-baric

Will caulk/sealer fix this problem?

Recommended Posts

I built a box for my 10" kicker cvx and it sounds great. Ported to about 35Hertz and being pushed by a kicker amp. But..............my wiring terminal lets a little air through. Can I open up my box and put some clear caulking over it to block the air off? It is a spring-style terminal just to let you guys know.

Share this post


Link to post
Share on other sites

Yea, some clear caulk should seal it right up


<First and only dual-alternator 'real' Saturn (pre 2002) on the planet>

Team Concepts, Team Shok Industries Team XS Power

Soon: Mystery subs + AQ20k :D

12.75 cubes net ~25Hz tuning 200 sq inches of port (lowz?)

AC position- 250 amp alt

Stock alt position- 225 amp alt

(2) XS Power D3100's

4 power+ 4 ground runs of 1/0-gauge to rear

152.1 @ 40Hz legal, certified...just getting started.

Share this post


Link to post
Share on other sites

Dont even open the box, just pop the terminal itself, and put some caulk around the inside of the rim that screws to the box, and screw it back down


Car : 1992 Civic CX Hatchback (Turquoise)

HU : Kenwood Excelon (Front USB!!)

Amp(s) : Deck for speakers, Crossfire VR2000 (Soon to be 2!!)

Sub(s) : Premier TS W2000spl X2

Speakers : Premier 6.5" 2-way REV Series Coaxial fronts, Premier 6X9 3-way rear

 

Quoted from Youtube "... ur beta off getin an audiobahn amp or sumin wid true power and snd quality. "

Share this post


Link to post
Share on other sites

I was thinking about doing this, but some air is coming through the wire holes themselves and I can hear it sometimes. Maybe around the edges and on the back of it, might as well just put it right over where the wire connects on the inside I guess?

Share this post


Link to post
Share on other sites

When ever you build another box just run your wires straight into the box. Drill a hole about 1/16th of an inch larger than the wire, run it it into the box and seal the hole from the inside.


Ami Creations: Professionally Built Affordable Enclosures

Specializing in custom enclosure design and fabrication

 

******* Now offering Do it yourself Box Kits *******

Follow us on Facebook!

 

For information on custom enclosures, DIY kits or HID kits please PM or email us at Mike.AmiCreations@gmail.com

Share this post


Link to post
Share on other sites

So tonight I took the terminal cap out and reconnected my wires to the back of it alot better and sealed itup with electrical tape and some caulking, the sound is all gone:)

Share this post


Link to post
Share on other sites

Seal it right off completely and run your wires through your port.


'11 Jeep Patriot

Head Unit - Pioneer AVH-P3200DVD

Front - Massive Audio CK69X

Front Amp - Massive Audio NX2

Rear - Infinity Kappa's

Subs - 8 Sundown SA-8 v2's

Sub Amp - AB VFL 450.1

147.6 @ 37Hz

Share this post


Link to post
Share on other sites
Seal it right off completely and run your wires through your port.

One word:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NO :nono:

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×