Hooked Ground to + and + to Ground...but


smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
So the amp is a JX10001d. Such a dumb thing to do(No bad smell came from the unit. Took about a minute to realize and unplug it) But the odd thing is with it wired correctly now the power light comes on the amp and everything seems fine. No fuses got blown anywhere and when the vehicle is turned off the amp switches to protect mode. Turn vehicle on it switches to power. Tried everything but can't get any sound to a sub(Tried multiple). I'm confused because the amp still powers on. Could something inside the amp be messed up? Is it safe to open it up and look without worrying about a shock? Cost so much money so I'm sad and depressed and hope one of you have a magical solution. Thanks for any info.

I will add I've been using the amp and sub for a long time. Never has issues in the past. Needed to clean out my truck so unhooked and pulled it all out. RCA cable to/from the deck is hooked up, everything seems good.
 
Last edited:
OP
S

smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
The inside of this thing looks mint. What exactly would be wrong with it? Nothing is burnt or smells burnt. I don't get it. I've seen people say something inside the amp gets fried when they do what I did and there could be smoke or smell but not in this case. Any ideas?

18667
 
OP
S

smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
lol but why? The power light still comes on so what exactly would be wrong with it? I'm poor as all hell and will try anything to get it going. I just don't get why nothing is burnt and the power light still comes on. What exactly happened to it?
 

firey_kimchi

Member
Dec 28, 2011
74
5
Misawa AB, Japan
At the top of the board by the power/ground inputs, it looks like the Q5 and Q6 transistors are toasted and have black soot. The Q6 transistor's middle leg is broken, too. I'm not an expert, just my observation.
 
OP
S

smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
At the top of the board by the power/ground inputs, it looks like the Q5 and Q6 transistors are toasted and have black soot. The Q6 transistor's middle leg is broken, too. I'm not an expert, just my observation.
hmmm. I'd like to look underneath. I'm scared to touch it in case its holding a charge. You have any idea if it'd be safe to start touching the board? Either way I appreciate the input. You're nice!!
 
OP
S

smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
How did you miss that? 💀 View attachment 18669
:( I plugged positive to ground. I'm just the kind of person who would miss that lol. Bought the truck used thats my only defense. Even tho there is clearly a blue cable running from the positive battery terminal.

This really sucks. Thanks people. Appreciate your time. Meanwhile my friend gave me a cheap Sony xplode 1000watt amp and another buddy gave me a type r 15". Amp overheats in 10 minutes. So thats real good. But man that thing pounds. Good times. Good times.
 

Popwarhomie

Team Lethal Pressure
Jan 22, 2010
6,520
378
Florida
:( I plugged positive to ground. I'm just the kind of person who would miss that lol. Bought the truck used thats my only defense. Even tho there is clearly a blue cable running from the positive battery terminal.

This really sucks. Thanks people. Appreciate your time. Meanwhile my friend gave me a cheap Sony xplode 1000watt amp and another buddy gave me a type r 15". Amp overheats in 10 minutes. So thats real good. But man that thing pounds. Good times. Good times.

Meh it happens. You can message an amp repair place and see if they can give you a round about quote for repair. Might not be worth it though. Shane Ekstrom in Florida does good work but shipping would probably be pretty costly.
 
OP
S

smmmokin

CarAudio.com Newbie
Oct 15, 2019
7
1
Canada
Meh it happens. You can message an amp repair place and see if they can give you a round about quote for repair. Might not be worth it though. Shane Ekstrom in Florida does good work but shipping would probably be pretty costly.
Appreciate it. I'll check around see if there's anyone around here. Might as well. Thanks again!
 
  • Like
Reactions: Popwarhomie

Timbo74

CarAudio.com Well Known
Aug 10, 2019
160
18
Wisconsin
Appreciate it. I'll check around see if there's anyone around here. Might as well. Thanks again!
From now on...check, double check, and triple check your connections, before installing your fuse! It pays to be meticulous, when installing sensitive gear.
Looking at the inside....that really don’t look like too hard of a fix, if you can get your hands on the Right components.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Trending topics

Latest classifieds