Hifonics Amp not supllying power to the speakers.


Feb 12, 2015
125
0
United States
I have a 1000W RMS Hifonics amp (HFI1000.1D) wired to 2 Rockford Fosgate P2's and recently, my amp stopped supplying power to the speaker terminals so i figured it was the amp, called for a replacement from Sonic Electronix and got the new one today, hooked everything up and still the EXACT same problem I was having. I tested the RCA ports with a pair or RCA's hooked up to a phone to see if it was my Line Output Converter or RCA cables, but I still got no signal from the speaker terminals. I double checked all my voice coils on my subs and they were all stable and equated out to 1.3 OHM wired in parallel, and I checked the compression on both cones and everything checked out . Also checked the power and remote voltages which came out to 12.5 and 14.3 respectivly. The ground is solid and the protect light is not coming on. What is going on!? Am i missing something??? //content.invisioncic.com/y282845/emoticons/confused.gif.e820e0216602db4765798ac39d28caa9.gif

 

CSCStang

Enclosurist
Mar 24, 2014
2,994
0
OC, Ca
I have a 1000W RMS Hifonics amp (HFI1000.1D) wired to 2 Rockford Fosgate P2's and recently, may amp stopped supplying power to the terminal so i figured it was the amp, called for a replacement from Sonic Electronix and got the new one today, hooked everything up and still the EXACT same problem I was having. I tested the RCA with a pair hooked up to a phone to see if it was my LOC or RCA cables, but i still not no signal from the speakers. I double checked all my voice coils on my subs and they we are stable and all equated out to 1.3 OHM wired in parallel, as well as the compression on both cones and everything checked out. Also checked the power and remote voltages which came out to 12.5 and 14.3 respectivly. What is going on!? Am i missing something??? //content.invisioncic.com/y282845/emoticons/confused.gif.e820e0216602db4765798ac39d28caa9.gif
And you're sure the amp is kicking on correct? To be sure, jump the remote to the + on the amp and make sure your ground is solid.

 

CSCStang

Enclosurist
Mar 24, 2014
2,994
0
OC, Ca
positive, i literally tore the whole thing down and did everything over, the amp is on and seems to be running stable.
I would try a different amp then. The only Hifonics I would recommend is the brx or the brz, the lower end ones aren't very reliable unfortunately.

 
OP
dubstepper1000
Feb 12, 2015
125
0
United States
I would try a different amp then. The only Hifonics I would recommend is the brx or the brz, the lower end ones aren't very reliable unfortunately.
That's what i was planning on doing, But being a poor college kid, I was hoping it didn't have to come to buying an entire new amp. I have a spare 4 channel laying around i guess i could try. What is weird to me is that the amp is brand new.

 
OP
dubstepper1000
Feb 12, 2015
125
0
United States
Hfi lines are all refurbished. They were discontinued awhile ago. One of their less reliable lines
Yeah i relize that now, I think im going for the BRX, Sonic Electronix said i can get in store credit back for the amp.

Off topic, I noticed that you have the soundqubed HDC318, my friend is actually considering buy that exact model with a 2200 RMS amp, how do you like them???

 

Jeffdachef

Gunz That Turn on Nunz
Feb 5, 2013
17,262
252
South Coast Metro, CA
Yeah i relize that now, I think im going for the BRX, Sonic Electronix said i can get in store credit back for the amp.
Off topic, I noticed that you have the soundqubed HDC318, my friend is actually considering buy that exact model with a 2200 RMS amp, how do you like them???
Bitchin good!

 

CSCStang

Enclosurist
Mar 24, 2014
2,994
0
OC, Ca
That's what i was planning on doing, But being a poor college kid, I was hoping it didn't have to come to buying an entire new amp. I have a spare 4 channel laying around i guess i could try. What is weird to me is that the amp is brand new.
Seems as though you've tried everything else so....

 

Beatin2door

Junior Member
Feb 11, 2015
17
0
Clarksville, Tn
All the hifonics amps have a diagnostic mode that will shut down power until its reset. To do this unhook your RCA's ,and leave power ground and remote wire connected, now turn the amplifier back on, if the diagnostic led lights there's an internal fault wit the amp if not cut power plug rca back into amp turn it back on and its reset. After the reset if the diagnostic lights back up its its a faulty input, either bad cables or the source unit. If it still in protect after all that disconnect all wiring from amplifier take a piece of speaker wire and connect the 12volt power terminal to the ground on amp, u will see a brief spark. This will discharge the capacitors and reset the drive card inside the amp. Then hook it all back up and try again. I hope this helps.

 
OP
dubstepper1000
Feb 12, 2015
125
0
United States
All the hifonics amps have a diagnostic mode that will shut down power until its reset. To do this unhook your RCA's ,and leave power ground and remote wire connected, now turn the amplifier back on, if the diagnostic led lights there's an internal fault wit the amp if not cut power plug rca back into amp turn it back on and its reset. After the reset if the diagnostic lights back up its its a faulty input, either bad cables or the source unit. If it still in protect after all that disconnect all wiring from amplifier take a piece of speaker wire and connect the 12volt power terminal to the ground on amp, u will see a brief spark. This will discharge the capacitors and reset the drive card inside the amp. Then hook it all back up and try again. I hope this helps.
My amp was never in protect mode, it is on and functioning and i have verified that there is good signal going in and my subs are fine, its just that the "New" amp i was sent was actually just refurbished very badly.

 

Beatin2door

Junior Member
Feb 11, 2015
17
0
Clarksville, Tn
Hmm yep I say off to the factory with it. I had a brz2400 I never had any problems with it. I played it full blast for 2 hours a day to and from work for a year it never even got hot during the summer.

 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Latest posts

Trending topics

Latest classifieds