Jump to content


Sign in to follow this  
dada777

Just had professionally installed sub and not happy about it advice?

Recommended Posts

Hi all!

Im new here and dont understand much about car stereo installation.
I own Honda Accord Touring which comes with premium sound , factory amp (450w) and subwoofer .
Recently i had professionaly installed aftermarket sub with aftermarket Amp.
Everything sounds ok but i feel front speakers are not loud anymore as they were before sub installation .
Actually sound that comes from front speakers now seam to be flat and worst than before sub installation.
If i turn off aftermarket sub off and turn on factory one (which is disconnected now) sound from front speakers is much better.
Im going to call shop tomorrow and ask them if it is normal, but i would also like to ask here some experts about opinion and advice what should i ask tomorrow when i call guy that installed it.
I have read somewhere if car has already factory amp they should use signal before that amp for sub. Is it something i should ask too ?

Share this post


Link to post
Share on other sites

Sounds like your sub/amp combo is overpowering your front speakers. Are you running an LOC by chance? Stock HU? I highly doubt they set the gain for ya on the amp to the sub to match everything else, which could also be another problem.


97 4 dr. Tahoe

Interstate battery

Pioneer DEH-80PRS

Polk Audio MM6501 comps

Wolfram amps coming soon, 3000.1, 125.4

2 Sundown Audio X 15's Tuned @ 30Hz.

Knukonceptz/Royal Excelene wiring

Share this post


Link to post
Share on other sites
38 minutes ago, Boomin_tahoe said:

Sounds like your sub/amp combo is overpowering your front speakers. Are you running an LOC by chance? Stock HU? I highly doubt they set the gain for ya on the amp to the sub to match everything else, which could also be another problem.

I dont know what is loc. Sorry. I was also going to change front component speakers tommorow but without adding aftermarket amp to them. I just read one post where people are saying adding speakers without amp will make sound worse. True? Speakers are infinity Kappa

Share this post


Link to post
Share on other sites

LOC is Length Of Cut. Lol...sorry coming from a machinist. But on a serious note, LOC (Line Output Converter)  is an aftermarket unit to use in any stock vehicle to hook up anything after market HU: Amp(s), subs, etc.

 

As for adding front speakers and making them sound worse, not really, but would be better with a nice 4 ch amp, it'll make them 1000x better when they have power. I'm in the process of doing the same. Also takes some tuning to make the speakers sound good as well as location.


97 4 dr. Tahoe

Interstate battery

Pioneer DEH-80PRS

Polk Audio MM6501 comps

Wolfram amps coming soon, 3000.1, 125.4

2 Sundown Audio X 15's Tuned @ 30Hz.

Knukonceptz/Royal Excelene wiring

Share this post


Link to post
Share on other sites

Could make them worse (quieter) without an amp on front speakers. My stock Camaro speakers (Boston Acoustic junk) were 2 ohm, so installing 4 ohm aftermarket speakers without an amp made them not near as loud.


Traded with, bought from: Anthony O, Mitchell0715, kuda, Chevy Blazin', Babs, Captain Obvious, ciaonzo

 

'13 Camaro SS/RS

Kenwood DDX9903S - Arc PS-8

Arc Audio XDi 1200.6 - Audiofrog GB10, GB25, GB60

Helix SPXL1000 - (2) Audiofrog GB12D4 IB

Share this post


Link to post
Share on other sites

Problem is i can find out about front speakers sound quallity only after they are installed and that will cost me more than 350$.  They are 2 ohms too. Sound from my front speakers is somehow distorted now,not clear after i put aftermarket sub. They sound like they are not strong enough. But they are oem and they worked before sub installation just fine

Edited by dada777

Share this post


Link to post
Share on other sites

Remember, the only difference between and amateur and a professional is, the pro gets paid. Doesnt mean they actually know more than the amateur.

Share this post


Link to post
Share on other sites

I would certainly see if the installer will sort out the current situation, then I would find a nice 4-channel amp for your front stage. Then start researching component sets that work with the power you have on hand.


Traded with, bought from: Anthony O, Mitchell0715, kuda, Chevy Blazin', Babs, Captain Obvious, ciaonzo

 

'13 Camaro SS/RS

Kenwood DDX9903S - Arc PS-8

Arc Audio XDi 1200.6 - Audiofrog GB10, GB25, GB60

Helix SPXL1000 - (2) Audiofrog GB12D4 IB

Share this post


Link to post
Share on other sites

what did the shop say?


Alpine 9887, Oz ME 180CS, RF R500X1D, 12" RE SE Sealed, Second Skin Damp Pro

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×