Jump to content


Sign in to follow this  
MmatsDude

Electrical problem

Recommended Posts

Sup fellas. Need urgent help before I take my car to an electrical shop.

 

2003 Lincoln town car

 

Have not installed no car audio equipment yet.

 

 

 

When I am driving the car and I use my turning signals either left or right turning signal it kills all the electrical on my dash board and the AC shuts off. The dash board starts going crazy with the gauges going up and down uncontrollably. Scared when this happens and I am on the freeway. Then after like 5 or 10 seconds everything comes back to normal and starts working properly.

 

It did this yesterday. I was pulling in to a parking lot used my right turning signal and boom it killed the AC off completely and the whole dash board off also. The car was still drivable but the steering wheel felt stiff as if the car was loosing power. Really weird.

 

Can the turning signals be causing a short when turned on? Interfering with other electrical components in the car?

 

Also today the car wouldn’t turn on at all. Only the stereo will turn on. Dashboard and AC like stated previously will not turn on. When trying to turn the ignition the car won’t respond it’s just completely dead but you could hear a clicking sound though as if the car wants to turn on.

 

This is driving me crazy. Help guys


thkf1mqd.jpg

Share this post


Link to post
Share on other sites

Ok guys I tried using the turning signals again While driving to see if it did it again.When vehicle engine is running and turn signals are actuated, the digital dash, turn signals, and air conditioner cuts off. Additionally, steering effort increases substantially. The duration may be momentary (less than 5 seconds) or last for a minute or longer. Frequency is 30+ percent of the time when the turn signals are engaged (left or right).


thkf1mqd.jpg

Share this post


Link to post
Share on other sites

IDK for sure what's causing the problems... mine did something similar with gauges, door locks, turn signals and window motors. Turned out it was a short in the power seat... lol... I found it by feeling the breakers (auto-reset ones) when it was acting-up. The lil things were in the interior fuse-box and controlled several circuits each and when opened-up they were HOT. I traced the circuit and started disconnecting what I could get to and eventually I got lucky (Narrowed down the area/circuit).... the drivers power seat was the issue, I removed it and took it apart and lo-and-behold a wire was rubbed down to the core for one of the motors, It still worked, my body weight was causing the short and only sometimes as well.

I wrapped the wire and zip-tied it out of the problem area and it's now fixed.

Could be something similar... electrical gremlins can be a PITA!

Hopefully that helps.


JVC KD-X350BTS, Sundown Sa-15 33.5hz 3.8ft3 ported, Synergy 3K@ 2 ohm, RF 500s, Polk DB comps, Cache Preamp/EQ... or...

JVC KD-X350BTS, Kicker S10L72 1.75ft3 ported, Synergy 3K @ 1 ohm, RF 500s, Polk DB comps, Cache Preamp/EQ

 

Share this post


Link to post
Share on other sites

probably a short however we did have to change the turn signal stalk and wires on 03 alero it have other stuff running through it or something.. search google for tht problem u may find answer on lincoln forum


KENWOOD X301 HU, PRECISION POWER Phantom 1000, FU 750 12, 2.1cfad ported, soundqubed 6.5" coax/doors, hp & lp xover on hu, AGM starting batt...

Boomin_tahoe said:
2 ohms rule

Share this post


Link to post
Share on other sites
IDK for sure what's causing the problems... mine did something similar with gauges, door locks, turn signals and window motors. Turned out it was a short in the power seat... lol... I found it by feeling the breakers (auto-reset ones) when it was acting-up. The lil things were in the interior fuse-box and controlled several circuits each and when opened-up they were HOT. I traced the circuit and started disconnecting what I could get to and eventually I got lucky (Narrowed down the area/circuit).... the drivers power seat was the issue, I removed it and took it apart and lo-and-behold a wire was rubbed down to the core for one of the motors, It still worked, my body weight was causing the short and only sometimes as well.

I wrapped the wire and zip-tied it out of the problem area and it's now fixed.

Could be something similar... electrical gremlins can be a PITA!

Hopefully that helps.

 

Dude that sounds like a pain in the but. Lol

 

I don’t even know we’re to start checking.

 

You know the fuse box that is by the steering wheel? Well When the car does not want to turn on I start hitting that fuse box a couple of times and by hitting it I manage to start the car back up. Weird bro. Should check all fuses first?

 

I know my problem is a short. But don’t know we’re.

 

The car started doing this when the fuel pump was changed. Should I take it back to the mechanic that did the fuel pump work on it?


thkf1mqd.jpg

Share this post


Link to post
Share on other sites

Nvm


buck.box.designs@gmail.com

I help with full system support, if you need advice

:yumyum: I just like making people happy :yumyum:

Share this post


Link to post
Share on other sites

I would post this in a lincoln specific forum first

 

Mention that it was after the fuel pump and see if any of the wiring is related. It could be your computer going bad, it could be a short in the dash panel, or the blinker wiring.

 

I'm betting it could even be a bad ground


I AM The Future of personal transportation, NOW!!
Pretty sure everyone on this site hates you (@JohnKuthe) more then me and that's very hard to accomplish.

Share this post


Link to post
Share on other sites

Low Voltage can cause several electrical issues in these newer vehicles also.Just another think to be considered.Had this happen in an 09 Volvo ..Bad bnew battery,had a cell that was only charging to like 11.4v


2)American Bass VFL Mini Hybrid 4480.1D@1ohm Ea 4)American Bass XFL DVC 4ohm 12s@2.06cu Ft Ea.@32htz CDT 6,5 HD6 Briax.,CDT CL60,CDT 25 tweets,Kicker KS25 tweets Autotek Mean Machine 99@2ohms,Autotek BTX 7204@40hms AlterStarts Alt 255A/Dallas,Tx,2)Orileys Super Start AGM batts(1more coming)Cadence CCA 0ga on Big 6,AudioTechnix 0ga CCA Kicker Kq9 Eq,Eclipse CD3000(lookingfor upgrade)StingerPro Distro,3)XS Scorpian 8in Scroll Fans 1998 3dr Xcab Chevy(under construction,but operational)

Share this post


Link to post
Share on other sites

Short to ground, ticking means bad relay. Listen to them while somebody tries starting it and replace the one that clicks. Low voltage would be easy to test for as well.

Share this post


Link to post
Share on other sites
Short to ground, ticking means bad relay. Listen to them while somebody tries starting it and replace the one that clicks. Low voltage would be easy to test for as well.

 

One is ticking. I am going to replace it. Will report back.


thkf1mqd.jpg

Share this post


Link to post
Share on other sites

I disconnected and reconnected all fuses and relays problem went away. Weird


thkf1mqd.jpg

Share this post


Link to post
Share on other sites
I disconnected and reconnected all fuses and relays problem went away. Weird

That is weird.Maybe your ECU may need be replaced soon?Or Brain for the Vehicle going out eventually?I dont know. I know that every Ford Ive ever owned i always had some retarded issue with them.Like those Coil pacs, fuel pump issues,blowers,lifters tapping,transmission issues, 3rd brake light out cruise control wouldnt work.Just some stuff


2)American Bass VFL Mini Hybrid 4480.1D@1ohm Ea 4)American Bass XFL DVC 4ohm 12s@2.06cu Ft Ea.@32htz CDT 6,5 HD6 Briax.,CDT CL60,CDT 25 tweets,Kicker KS25 tweets Autotek Mean Machine 99@2ohms,Autotek BTX 7204@40hms AlterStarts Alt 255A/Dallas,Tx,2)Orileys Super Start AGM batts(1more coming)Cadence CCA 0ga on Big 6,AudioTechnix 0ga CCA Kicker Kq9 Eq,Eclipse CD3000(lookingfor upgrade)StingerPro Distro,3)XS Scorpian 8in Scroll Fans 1998 3dr Xcab Chevy(under construction,but operational)

Share this post


Link to post
Share on other sites

That is weird.Maybe your ECU may need be replaced soon?Or Brain for the Vehicle going out eventually?I dont know. I know that every Ford Ive ever owned i always had some retarded issue with them.Like those Coil pacs, fuel pump issues,blowers,lifters tapping,transmission issues, 3rd brake light out cruise control wouldnt work.Just some stuff

 

My friend that works on cars electrically said that one of the fuses or relays was making bad contact and by disconnecting and reconnecting everything it fix the problem.


thkf1mqd.jpg

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×