What else BESIDES the HiFonics?

brothaknowles
10+ year member

Ok I'm sorry to hassle, but one last amp question. After reading personal HiFonics Brutus 1500D reviews, it doesn't sound so hot. People say that it doesn't come close to putting out what it claims, and etc... so what amp would you recommend for me to use? I have 2 12" Resonate Engineering HC's.... (they are duel 2 Ohm drivers) thanks, and look forward to your answer because I am anxious to get it all installed..

 

nosaj070
10+ year member

CarAudio.com Veteran
2,395
0
Chicago, IL
Well the Brutus wouldn't work well in your situtation, your subs can only be wired to two ohms and a .5 load, at 2 the hifonics is only sending 1000 watts, and Limitkid said it wasn't even that. It does put out its power at 1500, its actually even a little underrated at 1 ohm. You need to find an amp that is 2 ohm mono stable and puts out what you are looking for. You could get two 1000d's and they would really push those subs, but it may be out of your budget.

 

tobz
10+ year member

Independant Thinker
506
0
MN
People need to learn what power their cars put out. The hifonics at 14.4v will put out close to, if not the full 1500w @ 1 ohm. You really think your car is giving 14.4v's when your system is on? right...

 

nosaj070
10+ year member

CarAudio.com Veteran
2,395
0
Chicago, IL
People need to learn what power their cars put out. The hifonics at 14.4v will put out close to, if not the full 1500w @ 1 ohm. You really think your car is giving 14.4v's when your system is on? right...
I get 14.3 //content.invisioncic.com/y282845/emoticons/smile.gif.1ebc41e1811405b213edfc4622c41e27.gif

 
OP
B

brothaknowles
10+ year member

Ok, so no Hifonics Brutus... but then what? Because I am so ready to get this plugged in and bumpin, but don't know what amp(s) to choose... i am really not wanting to spend over like 350,400, which is probably asking a lot, but i dunno.. again, they are 2 HC 12's, dual ohm drivers... thanks for the help Also- RMS is 1200w, 1800w max

 

nosaj070
10+ year member

CarAudio.com Veteran
2,395
0
Chicago, IL
JBL 1200.1 does 1200 at 2 ohms and is a bit underrated.

2 BX1000d's would work quite well givin you 1000 watts a piece to the subs, but it would go over your budget a little bit.

 

EarDrummin.
10+ year member

Is this my Brahma?
3,542
0
Wanaque, NJ
Brothaknowles, I commend you for taking a different route than Hifonics for your RE drivers.

Secondly, I have a JBL1200.1.. it's indeed underrated. It also drops to 1 ohm quite cleanly, and is relatively cheap. Cons: No ssf, dirty power at 1 ohm.

Do me a favor, consider something other than what's repeated constantly on this board. As far as amps, I'd really like to see someone get something quality and share the results of the install with the board. Look at some PPI, Audiobahn, Mmats.. there's a ton of quality out there waiting to be used.

Overdone on this forum: Soundstream, JBL, Hifonics, and PG Tantrum is getting there.

I'm not saying don't get one of these because they're bad. I'm saying don't get one of these based on the chitter-chatter in this forum. //content.invisioncic.com/y282845/emoticons/smile.gif.1ebc41e1811405b213edfc4622c41e27.gif

 

tommyk90
5,000+ posts

THE WHOLE THING!!!
Actually, i thought they were needed for ported boxes because if you play notes below the box's tuning it can potentially damage the sub. That's not possible in sealed boxes because they are not tuned to anything.

 

nweibley
10+ year member

this:annoyinginsomanyways
475
0
Tampa, FL
subsonic filters are NOT needed for ported boxes.
I've ran two subs in ported boxes for a long time. never had a problem.
Yes, they are needed. Below the tuning frequency, the box loses it's reflexive quality and the sub begins to excurd tons without great output. Yes, you can run a ported box without one, but you really should be running one, otherwise you are wasting potential.

Graph the excursion in WinISD and tell me you dont need a SSF in a ported box.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Are you planning on upgrading the alternator and add extra batteries?
2
259
Seems kind of stupid to prevent helping others with advice on equipment from Amazon, doubt that Amazon is preventing this either. Pain in the arse!
14
516
Yep, I use 0-28k tones and pink noise. My amp actually came with some really high quality tracks that I've been using. RTA measurements are done with pink noise generally. But I also have a few...
14
2K
Yep, at the amplifiers. I get the same 14.7 volt reading when they cutoff too.
12
1K

About this thread

brothaknowles

10+ year member
Thread starter
brothaknowles
Joined
Location
Wichita, KS
Start date
Participants
Who Replied
Replies
32
Views
1,578
Last reply date
Last reply from
nweibley
Screenshot_20240221_115701_Brave.jpg

spokey9

    Feb 21, 2024
  • 0
  • 0
92E04DB4-A2FA-4193-A353-6DE01343F057.jpeg

Lt Ye Htun Oo

    Feb 20, 2024
  • 0
  • 0

Latest topics

Top