Rockford Fosgate RFR 3110 Rebuild

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
This is one of 4 subs I used to run in the early 2000's. This one ended up dead after being ran on a 1500 bd by itself lol. Man it rocked for a while though. The failure was a burnt lead. This is my first ever sub rebuild after being coached by DJ on here. I am very mechanically inclined as I am a pipe welder and build my own rock crawlers. But this stuff is very intricate and has been a challenging so far but completely doable with patience and measuring 3 times cut once type of things lol. Here are my pics so far. Waiting on my spring clamps from Amazon so I can't finish it out. I have the drop in built out and solid, shims were always used even on just the mockup, I didn't want anything binding. I cut the cone just a hair big so it slipped over easy so not to push the VC around. Anyways here yah go.
 

Attachments

  • Like
Reactions: audiobaun

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #2
A few more
 

Attachments

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #3
Dust cap picture is shot at a weird angle, it sits very flush, it actually fits very nice, just inside the stitched ledge.
 

djdilliodon!

CarAudio.com Exclusive
Nov 12, 2021
456
389
Did you measure winding width, divide it by two, plus half the top plate thickness, and mark the coil and line that up with the top plate 🤔🤔
 
  • Like
Reactions: Grimmjoww

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #8
Did you measure winding width, divide it by two, plus half the top plate thickness, and mark the coil and line that up with the top plate 🤔🤔
The old spider was sagging very bad, after I took the measurements it made it more evident. The landing where the old spider is glued to the coil is accurate, but the outside edge has almost 5/8" of sag in it.
 

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #9
Dude, cutting through that cone took forever lol, that thing is thick but light, crazy.
 

djdilliodon!

CarAudio.com Exclusive
Nov 12, 2021
456
389
The old spider was sagging very bad, after I took the measurements it made it more evident. The landing where the old spider is glued to the coil is accurate, but the outside edge has almost 5/8" of sag in it.
Older subs with poly cotton spiders all do that with time. Make sure all the joints you aren’t cheap with the glue! Thin layers built up and after each bead you do I like to wait about 20 seconds for everything to penetrate and then use the accelerator.
 

Attachments

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #11
This thing is going to be so stiff now, I'm going to need more amp lol, 750w aint gonna cut it.
 
  • Haha
Reactions: audiobaun

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #12
Older subs with poly cotton spiders all do that with time. Make sure all the joints you aren’t cheap with the glue! Thin layers built up and after each bead you do I like to wait about 20 seconds for everything to penetrate and then use the accelerator.
Dang your bead looks smooth lol. I did wait 20 seconds then used accelerator. I put 3 lights coats above and below the spider to coil and cone to coil. I should have enough left for 4 good coats on the spider to basket. The I stuill have a fresh tube or the rubber cement. Should I use the rubber cement on the dust cap to?
 

djdilliodon!

CarAudio.com Exclusive
Nov 12, 2021
456
389
Dang your bead looks smooth lol. I did wait 20 seconds then used accelerator. I put 3 lights coats above and below the spider to coil and cone to coil. I should have enough left for 4 good coats on the spider to basket. The I stuill have a fresh tube or the rubber cement. Should I use the rubber cement on the dust cap to?
Do NOT use the ca glue on the dust cap. What rubber cement did you get?
 
  • Like
Reactions: Grimmjoww

Grimmjoww

CarAudio.com Exclusive
Apr 18, 2021
295
117
  • Thread Starter Thread Starter
  • #14
Do NOT use the ca glue on the dust cap. What rubber cement did you get?
E6000 is what you said right? I have the lord of bass gold rubber cement that came in the kit to I haven't used yet.
 

Create an account or login to post

You must be a member in order to post a message

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Latest threads

Latest posts

Latest classifieds