Did I just do what i think i did?????

i3abyjay25
10+ year member

Get F'n Loud
i was outside redoing my wires...i took my rca running to my sub off my Mtx X/o and it made a huge differnce.. epic 150 normally showed 148 as my max spl... now its showing 153...and i can tell the differnce...

ok problem came when i was hooking up my componets to lager guage wire...w/ ACC on.. i drope the speaker wire on the door frame (ground) and all a sudden came loud hummin sound from all my speakers.. Did i just fry my RCA input on my 4 channel amp?

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Dammned that sounds good!! I usually dont eat out. But Hmm. Tempting
91
4K
Ya man. Thats No Good. As Stated. More than likely blew the power supply. I had an amplifier behind a rear truck seat and I forgot about the seatbelt behind it for the middle passenger, and one...
5
896
Yes, it was designed with the help of Steve at Amp Medics. They are great amps, I have many friends that run them.
5
1K
Send it means play it. I didn't say send it back. I'm sure it's fine.
43
5K
Thinking I will go 4th order. 3- 1 if i have the room for it. Motors to the front to help them cool faster.... and we are painting the baskets to match the air ride parts you can see under the...
12
1K

About this thread

i3abyjay25

10+ year member
Get F'n Loud
Thread starter
i3abyjay25
Joined
Location
Dallas, Georgia
Start date
Participants
Who Replied
Replies
0
Views
360
Last reply date
Last reply from
i3abyjay25
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0
IMG_5558.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top