Broken Amp

BooLeaN
10+ year member

CarAudio.com Elite
Hello, I have an American Bass CX1200D. I was just wondering if anyone can explain to me why it broke.

I was running it at 1 ohm mono, and yes it is 1 ohm stable. I had 4 gague wire going to it, with a 4 gague ground. I had the gain set at about 1/4 to 1/3. I turn my head unit's bass to 0, subwoofer level control to 0 and my volume to 30-33 / 40.

It was playing fine for about 2 weeks then today it just stopped working. The fuses are all ok, it just goes into protect. I checked for continuity in my ground, it's good. I tried unhooking the speakers and it still doesn't work. I completely took the amp out, then reconnected the ground, then power then REM and it still didn't work. Just goes into protect.

Now, one other thing. I'm not sure if I just don't know how to instal an amp or what the deal is, but this is the 3rd American Bass Amp that has broke on me.

One I was blamed for by using 8 gague power and ground wire. So I got screwed. One came DOA. And now this one.

I won't buy American Bass ever again but it just doesn't make sense that so many amps have broken in my hands. I have never broken an amp before and I have beat the living sh*t out of them. This 2nd one, I babied. I was soo scared of it breaking that I was way to easy on it IMO.

Any insight would be appreciated.

Thanks all,

Craig G

 

mud
10+ year member

Vagrant
Not really, except this makes me kind of happy that I didn't get one. You could take the cover off and see if you see any dead components though, that's always fun.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

So the car audio shop I took it to just claimed "bad wiring" and now it all works. Not really sure what that means but case closed! thanks everyone for your help
14
1K
Sounds like it's the digitizer in front of the LCD panel (a separate clear thin glass panel that responds to touch) is what broke. Technically it is not horribly difficult to swap, but yeah, as...
5
1K
OK, so turn your music on at moderate listening level and unplug the battery/alternator and see how long that capacitor keeps things playing. Report back with the results.
19
2K
  • Locked
COMPLETED broken amps mono
SSL EVOLUTION EV2.3000 2 CHANNEL MOSFET POWER AMPLIFIER
6
2K

About this thread

BooLeaN

10+ year member
CarAudio.com Elite
Thread starter
BooLeaN
Joined
Location
Canada Ontario
Start date
Participants
Who Replied
Replies
2
Views
379
Last reply date
Last reply from
mud
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0
IMG_5558.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top