Boost Issues


JustinStone

Vibe Rater
Aug 17, 2020
36
2
Florida
Purchased a diablo intune i3 8345, and put a tune on the Cruiser. The boost wasn't making the numbers advertised, and talked about on forums, so I got to tinkering. The stock SRT4 wastegate opened with the slightest pressure to it, so about a .25" shim was added to stiffen the spring. This allowed for 2 more pounds of sustained boost but i still have an issue. My boost spikes at 13-14psi around 1-4k rpm, then begins to rapidly fall as I increase in speed, reaching as low as 7psi. An audible whooshing sound is heard, much like the blow-off, around 7-14psi while still on the throttle. Stock SRT4 BOV's are supposed to take upwards of 20psi so this failure doesn't make sense to me (I replaced the BOV with a spare and no change).

Does anyone have any suggestions?

Boost leak tests aren't impossible with our equipment, just a pain in the ass since the engine bay is tighter than spandex; so I'm tryna save some trouble.
 
OP
JustinStone

JustinStone

Vibe Rater
Aug 17, 2020
36
2
Florida
Similar, yet probably unrelated topic. The turbo flutter I had, has disappeared. I understand that flutter is surge, and the BOV is to reduce this, but tbh I was a fan. A 45mm turbo should despool for a good while, so the disappearance of it, especially with 2-4 more psi, has me concerned.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 7)



Newest threads

Latest classifieds