New here! Got some questions and need some advice


Sabrewulf

Junior Member
May 1, 2018
3
0
Huntington beach
I have a 2016 jeep wrangler with the navigation, without the alpine system.

I had an old amp and 2 component speakers installed for the front, and a 10" subwoofer.

The amp is a hertz, 1160 watts, small in size and under my passenger seat.

The 2 components are installed for the front on the amp and the sub is installed for the back section of the amp (left).

I think the stereo shop is not very good as the sound is a bit muddy and crackles, if music is on pause, there is lots of static noise.

The bass (kicker comp 10" in sealed wedge) doesn't hit very hard, which I'm assuming isn't a strong subwoofer to begin with.

I've no idea on how to tune the amp for the speakers and the sub, is there a way to do this on my own? Shop wanted $200 to tune the amp.

Any advice would be helpful!

 

BOOMINGRANDPA

WOLFRAM FTW
Jan 8, 2017
7,090
22
NC
How would I confirm this?
well other than getting name brand of loc idk.. u can just go back to shop tell them it has static see if they can swap the loc or maybe check some grounds.. i feel sure they'll try to sell u an amp though, don't buy one there u can get good deal online and we know which ones are worth buying..

 

Gregor Clegane

CarAudio.com Veteran
Oct 12, 2012
635
4
Montreal, Qc
With the receipt.. If you're still using the stock hu that's probably what they've done unless your amp has high level inputs. Cheap LOCs are bound to make statics and/or introduce noises. A good one like the Audio Control LC2I sells for $80 but for best results you'd need a processor like the JBL MS8 witch is about $300 these days. It all depends on how far you want to take your system.

 
OP
S

Sabrewulf

Junior Member
May 1, 2018
3
0
Huntington beach
I was thinking about a new head unit to replace the navigation later on.

I've had systems on factory head units and never experienced the loud static noise before.

 

Gregor Clegane

CarAudio.com Veteran
Oct 12, 2012
635
4
Montreal, Qc
I was thinking about a new head unit to replace the navigation later on.
I've had systems on factory head units and never experienced the loud static noise before.
Maybe it's just defective... go back to your installer and tell him there's clearly something wrong.

 

audiobaun

CarAudio.com Veteran
Jun 28, 2011
10,154
120
USA
STATIC#$$##@$%//content.invisioncic.com/y282845/emoticons/wallbash.gif.1310150c49dd52e0fbe1813a0681e5c3.gif:wallbash: Those Kicker Comps arent really that bad of a sub in the right sized enclosure. I had a few and they did fairly decent in 1.6 sealed.Loud little jokers with some juice C10s

 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 2)



Trending topics

Latest classifieds