MTX Thunder 405

Cathlock
10+ year member

Member
36
0
Utah
I have a MTX Thunder 405, 5 channel amp. The amp makes a high pitch whining when poered up and the sub channel is not working at all. Can this be fixed or is it time to dump it and get a new amp? Does anyone know what is causing the amp to make the high pitch whining sound?

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Thanks buddy! Given me a lot to think about in terms of what to do; I've been watching YouTube videos on this stuff all day as well so I really appreciate the help!
4
356
You can wire those subs up @8 ohms if they are both SVC4 ohm subs,and that amp will run fine after being tuned properly https://www.the12volt.com/caraudio/subwoofer-wiring-diagrams.asp?Q=2&I=41
4
979
The 240 should be 2x40/ 2ch. rated at 11.9v. Should generate close to 50+ @14v rms. Only Rated @4 ohms bridged Mono.. Should be around 125 rms @4ohms @11.9v should do more @14v pretty sure it will...
5
2K
In 1990: The MTX MTA 225 had a MSRP of 549.95 25x2 0.02% THD S/N 102 12x 8 1/2x 2 3/8 The MTX MTA 250 had a MSRP of 649.95 50x2 0.02% THD S/N 102 14x 8 1/2 x 2 3/8
5
2K

About this thread

Cathlock

10+ year member
Member
Thread starter
Cathlock
Joined
Location
Utah
Start date
Participants
Who Replied
Replies
0
Views
1,175
Last reply date
Last reply from
Cathlock
IMG_0350.jpeg

DEW123

    Feb 23, 2024
  • 0
  • 0
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top