Kenwood display problem


Pmpat98

CarAudio.com Newbie
May 3, 2020
1
0
Milwaukee Wisconsin
Hey i jus bought this 06 pontiac g6 and it came with a kenwood kdc-x500 radio it was working good first week now out of nowhere the display suddenly froze up so i took the faceplate out to press the reset button as it said do and now the display dont work at all the radio still works cause its charging my phone but cant play music or see display any help before i just buy another one? Thanks in advance
 

audiobaun

CarAudio.com Veteran
Jun 28, 2011
10,548
248
USA
Hey i jus bought this 06 pontiac g6 and it came with a kenwood kdc-x500 radio it was working good first week now out of nowhere the display suddenly froze up so i took the faceplate out to press the reset button as it said do and now the display dont work at all the radio still works cause its charging my phone but cant play music or see display any help before i just buy another one? Thanks in advance
I know the G6 dash isn't an easy pull but not that hard to do. Neighbor and I replaced and put a small system in his last year. You may see if the wiring on the Hu is not loose or had come unattached due to road vibrations. Be best way to confirm IN Tact wiring/ Illum.wiring may have come loose. I'd try that. Take you about an hour or two all said and done. When pulled you can check the Hu at the battery with extra wiring also to confirm the face bulb may be burnt out as well. Try another reset at battery while testing. What I used to do before setting up test bench in garage for audios
 
  • Like
Reactions: Pmpat98

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 2)



Trending topics

Latest classifieds