freind has 2 10" MTX subwoofers what amp should he get?

91explorerV6
10+ year member

member
76
0
New York
Alright so as you read my freind has two MTX 10 inch subwoofers in a sealed box

There 600 watts Peak each and I think therer 400 watts RMS? maybe 300 not sure

on that one He asked me what amp to get and hes gonna buy whatever I tell

him to get so my rep as a car audio guy is on the line lol I gotta come through for him

hes on a budget so Im thinking a Profile CL1200 would be great for him but I

wanted to check on here first what do you all think from what Ive heard its a reliable

amp that does pretty close to the wattage that it says So unless you guys think its

a bad Idea im going to tell him to go with that by the way it would be good to keep it under $250 shipped but I think I could get him up to $300 shipped no Ebay its ok

to buy of the internet but it has to be a good company and absolutely NO EBAY let me know what you think thanks

 

Sleeklsc
5,000+ posts

CarAudio.com Veteran
7,319
1
...........
the majority of mtx subs that arnt dvc are 4 ohm's, so that would make a 2 ohm load for a amp if u get a 1 channel amp...the profile is 2 channel so u could run 1 speaker per ch and the speakers would get 450 rms each....thats enough for those subs...

 

antler skills
10+ year member

Member
no, they'd get 300 if they are 4 ohms each.

i suggest a jbl bp600.1. that way you can always upgrade subs later on and still have a decent amp. this can be had off http://www.ikesound.com for about $180. the bp600.1 is also 1 ohm stable, puts out 600@2 or 1 ohm, so no matter what voice coils the subs have they will be getting 600W RMS.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

If you buy a replacement OEM Radio Harness the colors will match up then you can use a wiring harness to connect to that. According to a few places if it doesn't have the stock oem amplifier then...
1
119
I use these and they work great. I splice them right before the LOC. One leg on the negative the other on the positive.
1
689
Nice, yeah, the ARTs did alright in stereo mode, 4 ohms, Didn't push them much. Was just getting into amp displays, seem to fit the part. I tried a few of the other PPIs, and soured on them as...
60
11K
Some circuits do have a constant draw, if there is a load that uses it, like radio settings, but it's not a battery pushing out that voltage. There is a load that is drawing that voltage. That's...
2
739

About this thread

91explorerV6

10+ year member
member
Thread starter
91explorerV6
Joined
Location
New York
Start date
Participants
Who Replied
Replies
5
Views
2,399
Last reply date
Last reply from
Sleeklsc
IMG_0350.jpeg

DEW123

    Feb 23, 2024
  • 0
  • 0
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top