whine

  1. D

    Alternator whine

    I have tried so many things but none worked so far. I have a JVC KW-DB93BT and a McHammer Mystic 5.1 amp. When i connect 1 RCA cable to my amp from my head unit there is no whine, but as soon as i put in the other RCA cable into the head unit alternator noise starts coming from the speakers that...
  2. R

    Alternator Whine

    Alternator Whine Description I have very very slight whine when my front channel amp is connected. But when I add my tweets and rear channel amp into the mix the whine becomes outrageous. Equipment Headunit: Kenwood dpx500bt Equalizer: Clarion eqs746 RCA: KnuKonceptz Bassik 2 Channel 5...
  3. N

    Ground loop isolator killed bass

    I have two 10" Kicker CompVT shallow-mount subs paired to an RE Audio CTX1600.2 amplifier. The subs and amp give off a whine that is simaltaneous with my engine RPM's and it pops and crackles like thunder whenever I'm using my phone while it's playing music. I bought a ground loop isolator...
  4. M

    alternator whine ?

    OK I am getting mad at this truck....just got it running right rebuilt trans... now my crunch 1000 4ch amp is whining but my mono amp is just fine........ Setup 0ga to dual anl fuse block 100amp on mono 60amp on 4ch 1.5ft 0 ga ground to distribution block 6in to each amp... 0 to frame off...
  5. N

    Engine whine. Need help, New system

    Okay, to start, Ive had 2 kenwood subs and amp in my car running off of a KDC-135 HU and its always worked perfectly. Recently I added 4 JBL door speakers and 2 Tweeters, everything worked fine running off the HU, besides not getting enough power. When adding the new amp for the door speakers, I...
  6. K

    Alternator Whine... Help Please

    Ok i have a 2004 yukon with all 1/0 wire a shuriken bt-120 in the back and am running an american bass sq 475. i have re grounded the battery amps and head unit in about 8 diff configurations, checked all of the speaker wire to make sure nothing is touching the frame, bought high quality rcas...
  7. D

    Amplifier Problem

    Hi there i have a MTX RFL805 amplifier and lately there seem to be high pitched whine coming from the amplifier. it will last for about 30 seconds and only happens when i start the car. When i shut the car off and restart it, the whine will not be there. I was curious what you all think is the...