Jump to content

Sign in to follow this  
jay T ?

Kicker

Recommended Posts

I have a question, and I need as much help as I can get.*

Here is what I have,*

Optima battery, Stock alternator of 150 amps, 4 gauge power and ground cable, 12 gauge speaker wire, Aftermarket stereo, Fosgate Punch 1000-1bd amplifier, and 2 12 inch l7 kickers. 2018 model.

 

When I higher my volume to like 3/4, both my subs rattle. Sounds like flapping rubber. I took my subs out of box, and they were still making that rattling/flapping sound. The subs are like 4 months old.*

 

I pressed on both sides of sub with fingers, and there was no scratching. Both subs are pretty firm. I checked the spider, and cone, and they both look perfect. All coils are on there right. No rips or cracks anywhere. I also tested all coils on both subs with multimeter, and all coils were reading at 3.7 and 3.8 ohms.

Is there anything else you guys recommend???

 

Oh yeah. And I also bought a Hifonics BRE20001.d and had it installed. Because I thought maybe my Fosgate amp wasn't working properly. But it's still doing the same thing. So it is doing same thing with both amps.

I bought the subs off a friend. He had them in his 2015 Camaro. He had them connected to his amp in his car. He let me hear them before I bought them. They sounded loud , and they didn't make any noise at all.

I bought them and I had them sitting for 2 months. Then I had them installed in my car. And that's when I heard them rattling.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×