Rainbow/ Kenwood RAV4

  • 2
    Participant count
  • Participant list

harriolo

CarAudio.com Newbie
I’m in the process of changing my audio system in a car I’ve just bought. I’ve bought a Pioneer ts-wx12108 sub. I’m just deciding between the car door speakers. It’s between the Rainbow EL-C260E and the Alpine S2-S65. Worth noting my mechanic whose going to install it will do me a deal on the Rainbows if I decide to go for them so they will be cheaper.

The Kenwood has a better peak power (240) rms power (80 watt) and impedance (4ohm) but worse frequency response (55hz-40hz)

The rainbow has worse peak power (120) rms power (60watt) and impedance 2.8ohm but better frequency response 60hz-20hz

I listen to a wide range of music but do listen to a lot of bass heavy stuff (but I feel like the sub should cover that)

Anyway would be great to know if you guys have any experience with either/ have thoughts on which I should go for? Is there really that much of a difference between them? bc the rainbow would cost me a fair bit less

Link to the Alpine and Rainbow

https://www.alpine.com.au/shop/speaker-systems/s-series-speakers/s2-s65/

https://frankiesautoelectrics.com.au/product/rainbow-el-c260e-2-way-6-5-165mm-component-set
 
First off, seems to me you have the specs backwards. Ignore peak, stick to RMS. Neither of them is going to do great at 60hz, that is really subwoofer territory The frequency response is virtually identical (for all practical purposes)

Which brings up another point. How are you going to feed them, aftermarket HU or amplifier or stock OEM? Regardless, that is important as 2.8 ohms may burn out the OEM HU or amp, unless the stock speakers are 2-3 ohms from the factory and the HU or OEM amp can Handel the lower impudence. Impedance is important and one is not better that the other per-se, more that it affects other aspects of the system such as your HU or amplifiers function and capabilities.
 
Activity
No one is currently typing a reply...

Similar threads

My question is, since 8.8v is quite a large voltage drop from 14v, is the amp getting hot, or it's power wiring? If the amp was causing the...
12
186
I got it to work, I was plugging in the subwoofer while the amp had power. I unhooked the remote turn on lead, then all speakers plugged in, then...
4
495
Thought I would update this thread… Couldn’t login over the weekend for some reason. Finally got the Kenwood installed last Friday… Had a little...
32
2K
Try going into your settings and look for system sounds. You may be able to adjust it there. Or, you can go into your phone settings, look for...
1
490

About this thread

harriolo

CarAudio.com Newbie
Thread starter
harriolo
Joined
Location
Melbourne
Start date
Participants
Who Replied
Replies
1
Views
392
Last reply date
Last reply from
Doxquzme
Screenshot_20240422_221646_Facebook.jpg

Bobbytwonames

    Apr 23, 2024
  • 0
  • 0
1713846388212.png

Random4thGuy

    Apr 23, 2024
  • 0
  • 0

Latest topics

Top