Horrible LOUD SQUEALING SOUND from my Boss Audio head unit 611UAB!


tbarber1027

CarAudio.com Newbie
Oct 14, 2019
1
0
Las Vegas, NV
I've had a Boss Audio head unit (#611UAB) DIGITAL Media AM/FM Receiver in my Honda Civic for the past year running fine.
Today while playing an MP3 file on a flash drive, suddenly the unit started SQUEALING VERY LOUD!
All the buttons on the head unit were useless, shutting off the ignition switch did nothing, pulling the fuse for the car stereo out of the dashboard did nothing! I had to disconnect the battery ground lead to get the noise to stop! After reconnecting the battery the stereo runs normally again.
Anyone ever had any kind of similar difficulty with Boss Audio head units?
 

Timbo74

CarAudio.com Well Known
Aug 10, 2019
158
18
Wisconsin
I’ve been having the same issues with my Pioneer avh-x4800bs.
I’ve already decided the next time it happens, I’m gonna just drop the cash on an Alpine, with apple car play.
My suggestion to you is to never buy Boss anything...it’s all junk!
Buying a reputable unit should solve your issues.
I bought my Pioneer through Facebook marketplace, I figured it was having problems, that’s why it was up for sale in the first place.
 
  • Like
Reactions: 2oldschool

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Trending topics

Latest classifieds