FI Bl-18v3d2/AAK-4000.1d... lovin' the output

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
I made some changes to my setup, upped power and stiffened the electrical a little bit. I'm seeing a nice gain overall, the enclosure had to be resized (box surgery -1.3ft3... 7.6ft3 net now) and now I'm able to put my new power to use. The amp does well...  the amp remote has some nice functions... clip light, voltage and temp and makes seemingly good power...  :wow:



The amp is mounted the same way as shown but I added some vibration isolation for insurance, all the amp mounting holes are over braced areas so even tho it's a single ply mdf box... It's doing well.

Maybe I'll get the chance to meter it soon, the enclosure is tuned around 40hz now and seems to do very well SPL-wise in my cabin around 44hz.

The other night I was showing it to someone and forgot to close the hatch glass... big mistake!.. I had a heart attack hearing that sound. Thankfully I just closed the glass and it was good to go, it's at least 145db... "ahem... cough, cough"... that's as far as I will predict as that meter seems to hate me. I've gotten some opinions, and I'll just digress now... we'll see.

Just put the baby Northstar in there today... it sure took awhile to as I had to fab some stuff and it's getting warm here in Phx... but it's done. I still have to see how much the lil' battery helps voltage as It ran late.

It's not a world beater, but I am happy for now.

 
Last edited by a moderator:

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
Had the Honda for awhile now, it's a tin can for sure.

I thought it was louder than it was from the wiper bounce but now it's doing a ton better than the lower powered systems I had in it previously.

The Fi Bl was worth the wait imho.

I'm extremely pleased at the current output.

 

fithwheel

Member
Dec 8, 2017
873
184
indiana
Is that a Honda/Isuzu? I can't remember the exact model but honda and Isuzu shared a vehicle back in the day. Think it was the passport Honda's first SUV. Think it's rebadged trooper iirr. Either way I've always had good luck with honda products from motorcycles to their cars. Most reliable vehicles I've ever owned anyway 

Figured you'd like that 18. I'd like to have 1 to play with. Haven't had an 18 yet. 

Lol doesn't look like you have room for a can of soda back there let alone a sack of groceries no wonder amplifier is mounted on the box. 

 

fithwheel

Member
Dec 8, 2017
873
184
indiana
Oh rodeo. Yeah I've gotta pilot sort of. Hmm rodeo reminds me of other bad car names.. at least it's not the Honda rodeo. 

 

MattinMO

Senior VIP Member
Dec 31, 2017
611
90
St.louis, MO
oh how I miss Palm trees. And what a basshead state AZ is. I suppose because a lot of the OG old school brands were Headquartered there.

 

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
oh how I miss Palm trees. And what a basshead state Az is.
Bet the local traffic ain't missed much, I'm in the east mesa/aj area so I've got some distance to contend with anytime I head out on the road.

The 60... yuck

I-10 west under construction... yuck

I-17... no comment 

Too many to list and anywhere during the day anymore really.

Jeez this city is getting big... idk how far phx metro is east-west but 50mi is probably close... maybe more

Love seeing those serious builds when I get out tho... some crazy ones for sure

 

MattinMO

Senior VIP Member
Dec 31, 2017
611
90
St.louis, MO
Bet the local traffic ain't missed much, I'm in the east mesa/aj area so I've got some distance to contend with anytime I head out on the road.
Most absurd congested traffic ever, just to show how overpopulated its becoming we sold our house almost 1 year to the day of ownership for $24k more then we bought it for with little to no improvements

 

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
I just ran a few errands and had a chance to test a few things. With that little Northstar it's hard to get voltage to go under 13V even trying on music, that said... setup to burp and with a 0db 44hz tone... I find it dropping to just under resting voltage and that's where I can hear the sub hitting it's limit in this enclosure. It's definitely putting out at that point and Idk how much more I can expect from this thing at the level I'm currently getting (after a point it really opens up). I'll meter it and see where it's at, then decide if I want to shrink the volume a tad... but the results at this point will probably tide me over for a bit. That Bl is a beast atm... not a record setter by any means but I'm grinnin'



:toast: ....  :wow:

 

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
Post a video...
Once I meter the thing I'll post a pic of my number and probably do a new vid... this vid was when the amp just got installed, single starting Agm with the 250A alt only and the sub was in in 9.04ft3 net. I could not really open it up... now it's a completely different animal with the enclosure volume change and stronger electrical. Jeezus... the thing does fine by me now... at least for a bit... 🤣



 

shredder2

CarAudio.com Elite
Nov 19, 2017
2,198
197
Az
Looks great! I bet there's a 150+ in there.
Maybe even sealed?.. who knows?

I've been shot down in flames by that T/L before... we'll see

My AC just starting popping fuses... arghh!

In Phx that's one thing I'll have to fix... the costs never stop...  :suicide:

 
Thread starter Similar threads Forum Replies Date
GPcarAudio.com Amplifier Classifieds 0
Inter007 Amplifier Classifieds 1