PPI PC650 blown amp, help

Breogan24
10+ year member

Member
87
0
NYC
recently sent to repair a PC650. The guy repairing it said that it blew all the output and power supply ICs , as well as 2 regulator ICs. Now my question is what could have caused this? I was just using the rear channels and sub channels bridged for 2 JLw3's. It ran fine for a month and then the unit would power on and off by itself repeatedly. I am just trying to avoid screwing it up since it will be repaired now.

Thanx in advance.

PS, the subs were wired at 3 ohms, and also i called PPI to ask them about this, but i think the guy i spoke with was lost. He told me that since I was only using 4 of the 6 channels my amp was producing too much heat and caused all my ICs to blow. Sounds like BS to me.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

  • Locked
I have aPC250on Ebay right now that works excellent couple days left on it at auction on the cheapies
3
3K
I am wondering if anyone has heard or have information on the new PPI vertical PC amps. Are they good for a budget sq class D amplifier. Any suggestions for a solid sq class D ? I have heard JL...
0
1K
  • Locked
THESE ITEMS WILL BE REMOVED FROM THIS FOR SALE THREAD ON AUG,16.2022 @9PM CT THANKS
2
1K

About this thread

Breogan24

10+ year member
Member
Thread starter
Breogan24
Joined
Location
NYC
Start date
Participants
Who Replied
Replies
0
Views
646
Last reply date
Last reply from
Breogan24
IMG_0350.jpeg

DEW123

    Feb 23, 2024
  • 0
  • 0
IMG_5559.jpeg

Buck

    Feb 22, 2024
  • 0
  • 0

Latest topics

Top