Jump to content

Sign in to follow this  
STC1709

Radio cuts in/out

Recommended Posts

Hey guys so I have had my system installed 4 years now. Just recently sound has been cutting in and out at a certain volume. If I have the radio playing above volume 38-40 it starts cutting out where everything goes silent than it comes back on. Higher I go with volume the more persistent the cutting out is. When I plug my iphone in the aux jack I can't go past volume 32-34 with the same thing occurring. If I keep the volumes low or below those levels everything runs fine.

 

I have a feeling I may need a new set of RCA cables, either that or it can be a battery wire or ground problem. Or possibly the headunit itself since it's an old radio (pioneer premier 8 years old). Any thoughts are welcome. Trying to get some insight before I tear the whole car apart. Also too the battery itself in the car is less than a year old.

 

Thanks in advance fellas

Share this post


Link to post
Share on other sites

Is your mids/highs amped? If so then first thing would seeing if the pioneer cuts off signal or if the problem is at the amp. Could be several things, from worn out speakers, to power/ground connections, to RCA failure... It is actually a pretty ling list.


DCCreationssigfinalimg.jpg

Share this post


Link to post
Share on other sites
Is your mids/highs amped? If so then first thing would seeing if the pioneer cuts off signal or if the problem is at the amp. Could be several things, from worn out speakers, to power/ground connections, to RCA failure... It is actually a pretty ling list.

 

Everything runs off the amp full system. 1 sub and 4 speakers. How would I go about seeing if it's the radio cutting off the signal? Thanks

Share this post


Link to post
Share on other sites

Is everything on one 5 channel amp? Does your pioneer shut off or dim out?

 

If everything is one amp simply looking at the amp to see if it goes into protect would be a starting point.


DCCreationssigfinalimg.jpg

Share this post


Link to post
Share on other sites
Is everything on one 5 channel amp? Does your pioneer shut off or dim out?

 

If everything is one amp simply looking at the amp to see if it goes into protect would be a starting point.

 

4 channel amp, I have the sub running on the rear channel by itself, and I have the left side of the car run parallel and the right side run parallel those speakers run on the front channel.

 

Pioneer radio does not shut off or dim out.

 

Ok I will have to check that

 

thanks

Share this post


Link to post
Share on other sites

The amp stays on, however once the music cuts out you begin to hear a psssssss sound coming from the amp then the music would come back in and the process would repeat.

Share this post


Link to post
Share on other sites

Could be an issue interanally with the amp. However, I would check your power and ground connections to ensure you are not having some sort of voltage issue.


DCCreationssigfinalimg.jpg

Share this post


Link to post
Share on other sites
Could be an issue interanally with the amp. However, I would check your power and ground connections to ensure you are not having some sort of voltage issue.

 

Alright will do thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×