Jump to content


Sign in to follow this  
tundra1221

rockford fosgate t2000bd

Recommended Posts

Item(s) for Sale:

 

Older Rockford fosgate t2000bd

 

 

Item(s) Description/Condition:

 

Does close to 3k at 1ohm

 

 

Price:

 

$400 plus shipping

 

 

Shipping and Miscellaneous Item Information:

 

 

u pay shipping

 

Item Pictures: will upload pics in a couple hours

(List pictures in this section, 1st picture should be your username/date if you have less than 10 positive feedbacks with the i-Trader system or less than 10 references that you have sold to in the past. (These must be listed in your signature, or a link provided to a feedback thread listing these references)).


COMING SOON!!!!

KDC-BT952HD deck

2 18" 3k ZV3's by SPLaudio

4 Cadence CVL88MBX mids

2 Cadence XT-20 tweets

1 Cadence C5 sub amps

1 Cadence C9 mid amp

Audio Technix wire/deadener

16v battery bank & HO alt

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By AspastIIcBean
      My list of gear as follows
      1x Boss mono block amp 2500w (old setup)
                  -twin pioneer champs Dvc 1200w 12"
      1x pioneer 4ch amp 1000w (60rms x4ch)
                   - 2x pioneer 6.5 260w (60w                                                 rms)component
                   - 2x pioneer 260w 6" (60w rms) coaxial
      Head deck : pioneer fxh755 bt (2 RCA out)
      Just wanted to know the best way to get the audio to the amps,
      1 RCA per amp?
      I've never delt with  4ch is just having 1 RCA going to give me full control or full quality on my 4ch. If I got 2 RCA splitters would that achieve anything useful?   
      Is high level worth using do I lose any quality compared to RCA? So out RCA into mono amp amd high level into 4ch amp?
      What's the best way about doing this. Is there any recommendations? I'm not wanting to spend too much money on this 🤣
    • By NeverPetABurningDog
      Hello friends.
      My amp and sub setup in my trunk works well except that the amp overheats regularly. It's a 4-channel amp, so I have two options for wiring the sub: bridged and unbridged. When it's unbridged, it's weak but it doesn't overheat as much. When it's bridged it sounds awesome but overheats after a few minutes, depending on the temperature outside. At first I thought that the ground wasn't good enough, so I moved it to the one of the bolts on the rear strut tower and sanded down every surface until shiny metal. I also cut the ground wire down to 18" or less. It still overheats. Maybe I need a higher gauge wire? I went to this audio shop and this guy told me to try switching the sub from channels 1 and 2 bridged to channels 3 and 4 bridged. So I did. Not sure what it did. I also might need to tune the setup more accurately, but I don't know that that has much to do with overheating issues.
      My car (95 Civic if you're wondering) came wired by the previous owner for a subwoofer. 4 gauge power wire from the battery to the trunk, 4 gauge ground, and a remote wire and RCA cables from the radio to the trunk. Power and ground are both OFC. Back in April, I got a used amp and a sub and put it in my trunk. I don't know much about audio/electrical, but I'll list what I know about my setup below:
      The amp I got is a PlanetAudio 4-channel amp (I know it's meant for speakers, but it at least works for the sub and I got it for $50). Here it is.
      The sub is a Pioneer. Don't know the model number, but the reading on the multimeter at the terminals tells me it's a 4-ohm sub. It's a single voice-coil subwoofer.
      What I don't understand is what bridging does to the impedance of the circuit. From my understanding, you want to match the impedance as close as you possibly can. So, if my amp is 4 ohms, I want a 4 ohm speaker to match it. Does bridging channels 1 and 2 put the impedance at 2 ohms and make it unstable? Or does running the sub on 1 channel put it at 8 ohms and make it more stable? I don't quite understand. 
      Another quick few things. I have no money, but I still appreciate advice like "get a new amp" or "get a fan to blow air on it" even though I won't be able to follow through with it until I pay for college. Advice concerning the wiring will be much more valuable to me.
       
      Thanks for the help, guys.
       
    • By jku
      Ok, so to start off I am new to the forum and I really hope you guys will be able to help me on this one. 
      My current setup is 2 kicker s12d solo barics (old school) and a memphis pr2.100 amp. The amp was an upgrade from my old MTX Thunder 325. 
      Ever since i swapped amps I had a minor issue where the amp wasn’t getting properly powered on and I could usually get the big blue light and power light to come on by hitting the amp (gently) or moving the fuses up and down. 
      Recently, the amp has been acting strange and it will not power on at all. I can get the big blue memphis logo to light up a little by wiggling fuses, but it eventually shuts off and the amp itself never fully powers on. 
      Today I changed my ground wire to a nice thick copper wire with a copper terminal. I also readjusted my remote wire to ensure all of my connections were perfect. It worked for about 35 minutes and then cut out, and now I can’t even get the amp to turn on for a few seconds. And yes, I checked the fuse under the hood. 
      Anyone have a clue what could be the problem? It’s an older system, but hasn’t been abused and worked fine for at least 4 months before this happened. I really would like to avoid buying another amp because I am currently buying a new headunit and some jeep mods. 
      Any input is appreciated. 
      Thanks, Conner
    • By jwoods330
      I have an alpine 1000 watt mono and powers up but won't push subs any ideas what or where I can go around akron\canton
×