Jump to content


n0ftInc

Haha.. I Should Know This By Now.. (623Posts)

Recommended Posts

Alright, I was thinking about buying a component set. Here is an example to help me figure this out.

 

So a 2-Way set says 100wts RMS. Does this mean I should look for an amp rated at 100x2 to run them, or since there is 4 speakers, should I look for 200x2..?

 

I feel so ashamed.. :crap:


'93 Corrado SLC

Alpine .. SI .. Adire .. Orion .. Optima .. KnuKonceptz

:chicken:

Share this post


Link to post
Share on other sites

100x2. The crossover for the components will direct the signal where it needs to go.


If my Avatar doesn't make sense to you: Click Here

hakuna matata

Share this post


Link to post
Share on other sites

Alright, next question..

 

Orion 2002..

2 x 50 watts @ 4 Ohm

2 x 100 watts @ 2 Ohm

1 x 200 watts @ 4 Ohm

 

Components..

RMS: 100W

Impedance: 4Ohms

 

Would I be able to hook these up to get the 2 x 100 watts @ 2 Ohm..?

I can, can't I..?


'93 Corrado SLC

Alpine .. SI .. Adire .. Orion .. Optima .. KnuKonceptz

:chicken:

Share this post


Link to post
Share on other sites

yes, you can't. Same on you for asking such a noob question.

 

On another note, 50w+ RMS (orion amps should be under rated) is more than enough for a lot of comps, 50w will get mighty loud.


Team Caraudio

 

Sony C90, 210 EQ

Seas 27TDF/C, RE XXX 6.5, custom xo (dyn 240GT sitting idle)

RF 60.2 amp

eD A15.22

Soundstream picasso 1400.1D

 

Bass drive-by's are uncool.

Share this post


Link to post
Share on other sites

Wait..

..So there is no way I can send out 100 x 2 to a set of 4Ohm componets? Even if I connected them in a 2Ohm load?

2_4ohmSVC_2ohm.gif


'93 Corrado SLC

Alpine .. SI .. Adire .. Orion .. Optima .. KnuKonceptz

:chicken:

Share this post


Link to post
Share on other sites

you would get a 2 ohm load for 1 channel if you wired them like that. so you would get 100 X 1 and 0 X 1 because you wouldn't have a speaker hooked upto the other channel.


2004 Dodge SRT-4

 

Kenwood Excelon X-890

2 JL 12W0's

Zapco AG350

Time to upgrade!!

Share this post


Link to post
Share on other sites

Create a free account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's free & easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×