speaker bass problem

bizzy323

Junior Member
Ok, I have a mb quart speaker that is running through a amplifier and also has a crossover, all my other 3 speakers which are the same thing work fine but one of them has a problem, whenever the bass goes up on the headunit it starts to make this loud noise like it cant take the power anymore, on my speakers amplifier its set to high pass fliter and the gains are down, how can i fix this problem?

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Definitely hard to beat, but they're deep. Didn't know these were still floating around.
13
2K
We don't have enough info, but I'm pretty sure you got something out of phase. When you fade to one side or the other the phase issue disappears.
8
100
I went with Kenwood Exelon. Audio Control amp and speakers. It’s amazing! I’m glad I did some research before buying. Thanks guys.
5
1K
Yes. Only thing is the leads will be encased in resin. Keep in mind that this is an assumption.
3
813

About this thread

bizzy323

Junior Member
Thread starter
bizzy323
Joined
Location
Los Angeles, CA
Start date
Participants
Who Replied
Replies
0
Views
557
Last reply date
Last reply from
bizzy323
20240724_191349.jpg

Bobbytwonames

    Jul 24, 2024
  • 0
  • 0
Screenshot_20240720_093355_Facebook.jpg

Bobbytwonames

    Jul 24, 2024
  • 0
  • 0

New threads

Top