Really need help. Totally lost


Sam b

CarAudio.com Newbie
Dec 14, 2019
5
0
Pa
I’m gonna start from top, loved car audio for the last 25 years. Always had some nice car stereos, then marriage and kids came.
Anyway. Now I have a 2019 rzr turbo. And I’m doing A nice stereo in it.

I started off going economical. I bought an overhead stereo unit that had a Bluetooth controller, an amp, and 4- 6.5” speakers in it. The maker is SSV works. They specialize in side x side stuff.

so after a day I realized that wasn’t gonna be good enough. I realized that the overhead unit had low outputs for additIonal amps.
So I went big, all marine stuff. I got a 10” sub with enclosure, that is powered by a mono block amp (both kicker). Next I got a JL 500 watt 4 channel amp, that amp powers 2- 8” rear pods, and 6.5” kick panels.
I wired up everything using high quality wires, rcas, distribution blocks, etc.

now the issue. I fired up the whole works yesterday, and everything powers on nicely and all, but the overhead units speakers will not play at all while the JL amp is hooked up, as soon as I unplug the RCAs from the JL amp, the kicker Amp, sub, and overhead unit works.

I’m getting my source from the overhead unit, I did have to split the signal (Ys) between the 2 amps of course.
For the life of me I cannot figure this out. Can someone give me any help at all as to where to even start. Both amps are hooked up right and the lights are correct, there’s no issue there. The JL amp will only work by itself, it won’t work at all with the mono amp or the overhead unit.
I have the JL amp running as a 3 channel amp to get the most power I can get to the hungry 8”coaxils in the rear.
Someone please help me.
 
OP
S

Sam b

CarAudio.com Newbie
Dec 14, 2019
5
0
Pa
Soooo 1000w or so??
What's the electrical system in this buggy capable of?
im really not sure But a lot of people run 2 amps in these rzrs. I’m just doing it a different way.
 

wew lad

wew lad inc
Mar 22, 2015
6,081
180
VA
Are all amps powered on when all amps have RCA inputs? Actually check that the lights are on, you could be dropping remote turn on voltage because multiple amps are in parallel.
 

n2audio

OPTIDRIVEN
10+ year member
Dec 29, 2001
5,659
43
Lawrence, KS
im really not sure But a lot of people run 2 amps in these rzrs. I’m just doing it a different way.
2 amps could be 300w or 2000w
Do you know these other guys with big sound systems haven't made elect mods?

Dealing with cars with 100-150A alt and relatively large battery capacity , it is often recommended to consider electrical upgrades at ~1000w rms.

From what I found these side by side's run stators with <50A output and low reserve batteries.
You may have other issues but I think some more digging on the capability of your electrical system to power two ~500w amps would be time well spent
 
OP
S

Sam b

CarAudio.com Newbie
Dec 14, 2019
5
0
Pa
Ok. I am at about 800 watts. So I did some messing around today. And I turned the gains on the JL amp all the way down, and the overheated units speakers started working. Until I turned the gains up slowly.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Users Who Are Viewing This Thread (Users: 0, Guests: 1)



Trending topics