no sound to speakers? Problem?

noleafclover803
10+ year member

Member
I'm going to be helping a friend hook up a couple of 12s in his Dodge Neon this weekend, but first we have a little problem. There is no sound to ANY of the speakers, all of which are wired to an after market JVC head unit...we bought a new head unit, but it did the same thing, so we returned it, since its obviously not the problem. It gets power fine, acts like its working, will play a CD, tune to stations etc, but just no sound comes out. He said this just started happening a couple weeks ago, and all speakers stopped getting sound at the same time.

What would cause this? All speakers can't be dead, and how could all the wiring go at once? I'm kind of stumped and I need to help him fix this.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Hertz makes good speaks as does Focal. Often times how "open" a system will sound depends on the vehicle's interior. Big wide dash boards tend...
11
1K
I would pull each speaker and test as well . Check with a DMM and a different HU or? as stated. A 12v battery and an Old HU usually works just fine
11
1K
"I don't have any crossovers" You'll need one to filter out the low frequencies leading to your sub woofer. They'll produce no sound then...
14
2K

About this thread

noleafclover803

10+ year member
Member
Thread starter
noleafclover803
Joined
Location
Kansas City
Start date
Participants
Who Replied
Replies
1
Views
545
Last reply date
Last reply from
sumone
FB_IMG_1712604583560.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0
FB_IMG_1712605484126.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0

New threads

Top