kenwood???

JOE RANDAZZO

Junior Member
I just recently bought a kenwood amplifier on e-bay. On the front of it it says HI-FI amplifier crosover pro- logic stereo 300 w x4ch= 1200 watts. On the amp crossover is only spelled with 1 s. The amp has no model # on it, does any one know anything about this amp? Thanks alot

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

I have 2 more questions about the Kenwood DDX9907XR / DMX907S radios. 1. If I am listening to a source and have that particular source displayed...
0
674
Honestly I don't think it would be hard for them to make it where you use android auto AND your own music source. They made it able to do so...
5
875
@Deiimos Hit it on the spot from the beginning of a bad ground. Excellent! Im happy to hear that you went through some procedures to locate the...
20
2K
I got it to work, I was plugging in the subwoofer while the amp had power. I unhooked the remote turn on lead, then all speakers plugged in, then...
4
1K

About this thread

JOE RANDAZZO

Junior Member
Thread starter
JOE RANDAZZO
Joined
Location
sarasota, fl
Start date
Participants
Who Replied
Replies
3
Views
552
Last reply date
Last reply from
ghs_wrestler189
1720923419724.png

Jimi77

    Jul 13, 2024
  • 0
  • 0
1720923400238.png

Jimi77

    Jul 13, 2024
  • 0
  • 0

New threads

Top