clipping with momo/polk mc650

trungthiendo
10+ year member

Senior VIP Member
i get clipping at moderate volumes...

i'm just using the head unit to power these for the time being...

head unit is an old jvc 45 x 4 peak.

the wires are just crimped with electrical tape covering them...i didn't have a solder on hand, but will solder them together when i have the chance

aniways any suggestions on why it is clipping???

volume is at 23 when i get clipping on certain songs

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

I would assume they are pretty accurate as long as they are directly tied into the clip circuit on the amp. Having said that, the signal traveling...
11
984
Don't recall off hand. Both single dins. One excelon, one not.
3
985
1. make sure you wired your subs right... https://jlaudio.zendesk.com/hc/en-us/articles/204374200-Dual-Voice-Coil-DVC-Wiring-Tutorial 2. set...
10
1K
Even a basic TL072 will do this function just fine. LoL. The joys of comparators!
34
6K
I would pull the HU and bench test it. Can be done with a 12v battery on a non-metal work bench easily enough.
16
2K

About this thread

trungthiendo

10+ year member
Senior VIP Member
Thread starter
trungthiendo
Joined
Location
amherst, ma
Start date
Participants
Who Replied
Replies
0
Views
582
Last reply date
Last reply from
trungthiendo
FB_IMG_1712604583560.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0
FB_IMG_1712605484126.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0

New threads

Top