audio cutting out

95transam

Junior Member
1
0
nj
ok i replaced the amp that goes to my speakers because my old one had a blown channel. the old one was a planet audio 600 watt, the new one i replaced it with is a sony xplode 600 watt. now when i crank up the volume up to a good amount my speakers cut out. i have to turn the power off then turn it back on for the music to come back on. is it because the new amp isnt as powerful? btw everything in my car is planetaudio (subs, speakers, amp to subs, with a pioneer headunit) anyone know whats goin on here? help is much appreciated.

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Restarting the phone every 1-2 days is a plus too. My moms phone is useless by the third day of not restarting. As soon as it's restarted it's fine.
11
1K
https://www.amazon.com/dp/B0B3X3C7RD/?tag=caraudiocom-20 This is one of the better reviewed budget touchscreens. I just about pulled the trigger...
3
134

About this thread

95transam

Junior Member
Thread starter
95transam
Joined
Location
nj
Start date
Participants
Who Replied
Replies
0
Views
427
Last reply date
Last reply from
95transam
FB_IMG_1712604583560.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0
FB_IMG_1712605484126.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0

New threads

Top