amp is cutting out...

Ryde _Or_Die
10+ year member

Senior VIP Member
321
0
Tampa, FL
Well I installed my system about 3 weeks ago and everything has been fine so far. I was having some problems with my tweeters on my components cutting out but now my amp is just going into protect whenever I turn my stereo up at all really. So what can be wrong besides the amp? Thanks.

 
I messed around with it along with all the rest of the speaker wires, remote and power and I turned it up slowly and it was fine. In case the amp is bad, whats the best amp I can get from thezeb.com for highs and put out at least 80x4rms @ 14.4 volts? I might return this amp and get another.

 
I have a Profile CA640. Not sure if its bridgeable but I think it is. I'm just running my highs off it and want more "cleaner" power out of it anyways so if its messed up I'll get something else.

 
actually, my friend used to have an amp that would cut on and off but it turns out it is his RCA cables or jacks in the back of his cd player

you might want to check that out too.

Sorry if im tellin you too much all at once.

eston

 
In case its not, whats a good clean amp that puts out close to 100rms x 4 for highs? I don't want to spend more than like $200-250 really. Are rockfords good for highs?

 
Activity
No one is currently typing a reply...
Old Thread: Please note, there have been no replies in this thread for over 3 years!
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

About this thread

Ryde _Or_Die

10+ year member
Senior VIP Member
Thread starter
Ryde _Or_Die
Joined
Location
Tampa, FL
Start date
Participants
Who Replied
Replies
18
Views
972
Last reply date
Last reply from
Ryde _Or_Die
FB_IMG_1712604583560.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0
FB_IMG_1712605484126.jpg

Bobbytwonames

    Jul 19, 2024
  • 0
  • 0

New threads

Top