Closed Thread
Results 1 to 6 of 6

Reload Thread: NO power to head unit

  1. #1
    Steve Lama's Avatar
    Steve Lama is offline Junior Member



    Join Date
    Jul 2002
    Location
    PA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon33 NO power to head unit

    I recently purchased a JVC-S580 head unit. After connecting the 12v and ground wires i cannot get any power to it. I also had this problem with two other aiwa head units and took them back thinking they were broken. I am trying to put it in an 89 pontiac firebird. My after market tape player still works when i reconnect that so i am confused as to where the problem is. The negative battery terminal was disconnected so im sure i havent shorted it. Any suggestions?







  2. #2
    Join Date
    Apr 2002
    Location
    sherwood park, AB
    Posts
    40
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    make sure ur remote wire is correct. u can have the power and ground right but u need a remote to turn it on.To check it run a wire from the remote on the headunit and fuse it into the fusu box under the radio fuse! this is a switched remote so that when the ingnition is turned on teh power is sent to turn the radio on check that or try runing a power wire rigth from the battery.




  3. #3
    chris229's Avatar
    chris229 is offline CarAudio.com Elite



    Join Date
    Apr 2002
    Location
    Wilm, DE
    Age
    35
    Posts
    1,107
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    do this-- twist the radio's turn-on and the radio's power wire together. connect them and the ground directly to the battery. It should power up. if it does get a test light or a volt meter and test--- power,turn on ,ground for the radio.




  4. #4
    Steve Lama's Avatar
    Steve Lama is offline Junior Member

    Threadstarter


    Join Date
    Jul 2002
    Location
    PA
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    How do i connect straight to the battery or the fuse box?




  5. #5
    Join Date
    Apr 2002
    Location
    sherwood park, AB
    Posts
    40
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    well to just check it i attached a wire loosely to the radio fuse in the fuse box and then the power wire to the power wire in the wiring harness this is to just check the remote. if that still doesnt work double check all the connections.




  6. #6
    Join Date
    Apr 2002
    Location
    sherwood park, AB
    Posts
    40
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    to the battery all you gotta do ias run a wire fromthe pwoer wire to the postive terminal on the bat . if this slal still doesnt work then assk someone who knows what thre doin to take a look. peace




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum