Closed Thread
Results 1 to 9 of 9

Reload Thread: fuse keeps blowing...

  1. #1
    IshbOO's Avatar
    IshbOO is offline Senior VIP Member



    Join Date
    Aug 2004
    Location
    St.Louis, MO
    Age
    27
    Posts
    336
    Post Thanks / Like
    Mentioned
    0 Post(s)

    fuse keeps blowing...

    I was riding around yesterday and my fuses blew on my amp. Today I went to get new fuses, replaced them. Then hooked it back up, then when I start the car my inline fuse breaks under the hood. I blew three in a row, I can't seem to get to the point when the map turns on, it blows before anything happens.

    Anyone know what I could do to solve this problem, I got a local comp to be at next weekend.

    I blew 2 60amp fuses, then went to an 80amp and blew it, and this is all on a 4g. power wire.



    Ca.com Refs: BLD 25, tez4life
    Ebay Refs: http://myworld.ebay.com/jdmjunkeee

    FS Orion HCCA-D2400, 12" SS RLP, 15" SS RLP




  2. #2
    cappy72's Avatar
    cappy72 is offline CarAudio.com Elite



    Join Date
    May 2004
    Location
    NY
    Posts
    907
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    sounds like something is fvcked up




  3. #3
    old basshead's Avatar
    old basshead is offline Rockford Power



    Join Date
    Jan 2005
    Location
    shorview, MN
    Posts
    39
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    start @ the battery and go back check everything on the power cable it sounds like you got a break in your cable DON'T GO UP TO A BIGGER FUSE!!!!!!



    NEVER 2 LOUD 160

  4. #4
    Join Date
    Nov 2004
    Location
    Grove City, OH
    Age
    28
    Posts
    2,236
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    Yeah i'll agree. DONT PUT A BIGGER FUSE IN THERE

    check where the wire rubs constantly on something, or where maybe some loose wire got grounded... or something.

    9 posts left




  5. #5
    ntense702's Avatar
    ntense702 is offline CarAudio.com Elite



    Join Date
    Mar 2005
    Location
    Las Vegas
    Age
    28
    Posts
    1,593
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    yeah sounds like a loose wire of some sort, to be on the safe side check all of your wires and make sure everything is connected good



    AVH-P4900, Overdrive, Epic 160, PPI 1000/2, Pro 60s, a3000db, SSA Icon 12, Fisher Custom.


  6. #6
    IshbOO's Avatar
    IshbOO is offline Senior VIP Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    St.Louis, MO
    Age
    27
    Posts
    336
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    I guess I will check out all my wiring then, and my grounds especially. I'm just hopeing my amp isn't fcked up.



    Ca.com Refs: BLD 25, tez4life
    Ebay Refs: http://myworld.ebay.com/jdmjunkeee

    FS Orion HCCA-D2400, 12" SS RLP, 15" SS RLP

  7. #7
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,439
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: fuse keeps blowing...

    If you blew the fuses inside the amp too, then the amp has issues.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  8. #8
    IshbOO's Avatar
    IshbOO is offline Senior VIP Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    St.Louis, MO
    Age
    27
    Posts
    336
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    Well, I went to the local shop today, right as I said "when i turn on my car or my battery, my inline fuse blows" he said my amp was blown. So I have to miss out on this local comp, miss out on building my new box, and miss out on any nice music until i get this fixed. I have it under warranty and it will take 4 weeks to get it fixed. The only thing I could try is to rewire everything and make sure everything has nice connections such as the ground. But it has worked fine for a while, and im pretty sure the wires are fine.

    If anyone else has any other suggestions let me know.



    Ca.com Refs: BLD 25, tez4life
    Ebay Refs: http://myworld.ebay.com/jdmjunkeee

    FS Orion HCCA-D2400, 12" SS RLP, 15" SS RLP

  9. #9
    pks71's Avatar
    pks71 is offline Senior VIP Member



    Join Date
    Jun 2004
    Location
    nova scotia
    Posts
    202
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuse keeps blowing...

    Disconect the amp. put a fuse in. If the fuse doesn't blow, u guta amp issue




Closed Thread

Similar Threads

  1. FUSE keeps blowing after turning on.
    By v62kaccord in forum Amplifiers
    Replies: 18
    Last Post: 02-04-2005, 03:37 AM
  2. Amp is blowing a 5 amp fuse???
    By AndrewFlanders in forum Wiring, Electrical and Installation Help
    Replies: 11
    Last Post: 11-20-2004, 10:37 AM
  3. Fuse keeps blowing...why????
    By Lewbrah485 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 06-05-2002, 10:25 AM
  4. Fuse keeps blowing...why????
    By Lewbrah485 in forum General Discussion
    Replies: 1
    Last Post: 06-03-2002, 04:03 AM
  5. head unit blowing fuse
    By tommybad in forum General Discussion
    Replies: 2
    Last Post: 04-23-2002, 02:17 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum