Closed Thread
Results 1 to 12 of 12

Reload Thread: why wont this crossover set up work?

  1. #1
    vwtoby's Avatar
    vwtoby is offline Member



    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    why wont this crossover set up work?

    ok...so i went to set up my front stage today...its comprised of two 6.5 pioneer premiers and one tweeter in each door....being run off one zr240 amp runnning (supposdly) 2 ohm stereo.

    thay are wired so that the input from the amp goes to the first crossover, this sends signals to the first mid and tweet, the second passive crossover gets the input as well, thus parallel for both crossover inputs, and send the signal to the second mid.

    However, i go to adjust the gain and the amp cuts out? and will only run on the lowest gain setting...

    i unplug the second crossover and run 4 ohn stereo into the one crossover with one mid and tweet, no issues what so ever....fine..


    so i thought that my amp coudl take 2ohm stereo....but is this what it sees in the first configuration?


    any help woudl be appreciated


    thanks







  2. #2
    johnecon2001's Avatar
    johnecon2001 is offline SSA/ROE Super-Møderator



    Join Date
    Aug 2004
    Location
    Phoenix, AZ
    Age
    31
    Posts
    5,137
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    crossover probably adds some sort of load to the amp. Your probably lowering it to too low of and ohm load for the amp.




    Don't PM me, I'm not here. Find me on SSA or ROE
    No, I won't re-upload the Big3 pictures. Don't ask.

  3. #3
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,437
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: why wont this crossover set up work?

    The setup you describe would be 2 ohms. Apparently your amp has issues.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  4. #4
    vwtoby's Avatar
    vwtoby is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    thats what i thought...so i swapped amps...anther zr240, albeit with the same SWX module, and it did the same.....maybe its the module




  5. #5
    Moe Lester's Avatar
    Moe Lester is offline 1/3 of TEAM PWNAGE



    Join Date
    Dec 2003
    Location
    Houston, TX
    Age
    27
    Posts
    3,614
    Post Thanks / Like
    Images
    10
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    are you sure you arent bridging it for 2 ohm mono? if its a 2 channel, and you are running a pair 4 ohm components, each channel should see 4 ohm and work fine. If you are bridging the amp into a 2 ohm load, each channel is seeing 1 ohm.




  6. #6
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,437
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: why wont this crossover set up work?

    What's an SWX module?

    You did try running BOTH sets of speakers separately, right? All is well? Sounds goodly?



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  7. #7
    vwtoby's Avatar
    vwtoby is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    no i have a 2 4ohm sets in parallel on each channel...so 2 ohm stereo....works fine when only one mid used (one crossover)...


    SWX is kickers crossover for the amp....set to 100hz plus for the mids....that then gets chopped up by the passives




  8. #8
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,437
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: why wont this crossover set up work?

    Is that crossover external? Got any links for it?



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  9. #9
    vwtoby's Avatar
    vwtoby is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    its internal...well...slides into the amp....

    set to high pass now

    http://www.kicker.com/images/archive...%20systems.pdf




  10. #10
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,437
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: why wont this crossover set up work?

    According to the specs, that amp is stable to 1 ohm in stereo. It should handle 2 sets of 4 ohm components easily. Dunno what else to tell ya... POS I guess.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  11. #11
    vwtoby's Avatar
    vwtoby is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    humm....dont think its the amp as both do it...

    heres to questions:

    1) can i wire a crossover output to 2ohm (ie. run both mids off one crossover) and not change the frequecny cut off etc?

    2) if the plus and minus's were mixed up between mids would that show a different loading resisitance...dont think so?


    thanks

    ohm how do you like your kicker comps maylar?




  12. #12
    vwtoby's Avatar
    vwtoby is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    canada
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: why wont this crossover set up work?

    anyone?




Closed Thread

Similar Threads

  1. CDT HD-62 Crossover
    By boister77 in forum Speakers
    Replies: 5
    Last Post: 11-10-2004, 04:37 AM
  2. Opinions on this set up?
    By TexasA&M in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 10-27-2004, 02:44 PM
  3. CDT Crossover
    By Nikuk in forum Speakers
    Replies: 12
    Last Post: 10-26-2004, 06:28 PM
  4. How do you know what to set the gain as?
    By torn eMericas in forum Amplifiers
    Replies: 7
    Last Post: 10-05-2004, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum