Closed Thread
Results 1 to 6 of 6

Reload Thread: Setting crossover on Kx400.1

  1. #1
    Hing's Avatar
    Hing is offline Iceflammer



    Join Date
    Aug 2004
    Location
    Singapore
    Age
    35
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Setting crossover on Kx400.1

    Need advice on how to set the crossover on a Kicker Kx400.1.
    What is the crossover for?







  2. #2
    johnecon2001's Avatar
    johnecon2001 is offline SSA/ROE Super-Møderator



    Join Date
    Aug 2004
    Location
    Phoenix, AZ
    Age
    31
    Posts
    5,137
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Setting crossover on Kx400.1

    what are you running with the amp.. cant tell you what to set it at if I don't know what your powering.




    Don't PM me, I'm not here. Find me on SSA or ROE
    No, I won't re-upload the Big3 pictures. Don't ask.

  3. #3
    Hing's Avatar
    Hing is offline Iceflammer

    Threadstarter


    Join Date
    Aug 2004
    Location
    Singapore
    Age
    35
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Setting crossover on Kx400.1

    I'm powering one S12L7 ported with it.
    It's the old L7 with black cone.
    Max power is 750w for that sub.
    Rms i'm not sure

    tks




  4. #4
    uncleroman's Avatar
    uncleroman is offline Member



    Join Date
    Oct 2004
    Location
    clear lake texas
    Posts
    54
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Setting crossover on Kx400.1

    80hz




  5. #5
    JoseMCeee's Avatar
    JoseMCeee is offline $tack



    Join Date
    Sep 2004
    Location
    Bay Area, CA
    Posts
    2,250
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Setting crossover on Kx400.1

    I dont think the recommende wattage for that sub is still 750 since it is in a ported box. Its probably 600 or so now. 100 hz is a good setting for the Xover.




  6. #6
    Hing's Avatar
    Hing is offline Iceflammer

    Threadstarter


    Join Date
    Aug 2004
    Location
    Singapore
    Age
    35
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Setting crossover on Kx400.1

    Tks guys

    WIll try 80hz, 100hz & see which will sound better for me.




Closed Thread

Similar Threads

  1. Component crossover and amp crossover
    By GX93117 in forum General Discussion
    Replies: 3
    Last Post: 10-02-2004, 02:58 AM
  2. to crossover or not to crossover?
    By Sspider in forum General Discussion
    Replies: 2
    Last Post: 08-04-2002, 11:30 PM
  3. How to hook up a Electronic Crossover? Need HELP ASAP
    By nofriends46 in forum General Discussion
    Replies: 2
    Last Post: 05-16-2002, 03:28 PM
  4. Replies: 2
    Last Post: 05-11-2002, 10:28 PM
  5. Passive Crossover Networks
    By ramos in forum General Discussion
    Replies: 6
    Last Post: 01-15-2002, 08:40 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum