Closed Thread
Results 1 to 4 of 4

Reload Thread: Installing 2nd Amp To Speakers : Help Please

  1. #1
    omnipseudo's Avatar
    omnipseudo is offline .4Wheelin Sound Addict



    Join Date
    Apr 2004
    Location
    Vail, Colorado
    Age
    28
    Posts
    50
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)

    Icon32 Installing 2nd Amp To Speakers : Help Please

    Hi, I currently have a Boss 700w 2ohm amp powering my 2 Kicker CVrs off of my Sony HU. Now, im trying to wire my rear roll-bar speakers (Jeep Wrangler) to an amp that was given to me. Its a Pioneer GM-X252 and it says its 2ohm stable at 40wx4 chans...I wired the amp just like normal, ground to body, power to battery, rem to hu, rcas to rear pre-outs on hu. I used 8 gauge power and ground wire with a 20 amp fuse in the power wire, same as the amps fuse. But I get no sound. Ive tried grounding it to the same place as my other amp, different place, daisy-chaining the REM wires, having both rems to the HU, no sound.

    A main Q i have is on this amp, when its 'on' does the light turn green? The light on top is red right now, and id assume this is some sort of stand-by mode? Or maybe its just one color. My friend doesnt know as hes never used the amp. Any suggestions/comments that may solve my problem would be helpful! Thanks in advance.



    2000 Jeep Wrangler Sport
    Tweets : In progress
    Speakers : 2 Alpine 4x6 SPS 2-Way and 2 Boston 5.25" RallyX
    Head Unit : Sony CDX-F7005X
    Amp : Boss 700w 2chan, 2ohm stable (Lookin for a new one)
    Subs : 2 10" Kicker Comp VRs
    Box : Sealed Custom QLogic




  2. #2
    UrbanSounds's Avatar
    UrbanSounds is offline Member



    Join Date
    Aug 2004
    Location
    Orange County, CA
    Posts
    106
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Installing 2nd Amp To Speakers : Help Please

    If Im not mistaken the Boss amps have both the green and red light. The green one will light up when the amp is working and is hooked up as it should be. The red light comes on when there is something wrong with the wiring or when it has blown a fuse or when it just no longer is working.

    A way to find out if your amp is working or not. Unplug your other amp and replace it with the boss amp using the same wiring of your other amp. If the red light still turns on than you know its your amp. If the amp is no good, you can probably take it back or send it back to boss and they will replace it for you. All you pay is one way shipping cost.

    If the amp turns on than its probably the wiring. Also it may be there is not enough power going to your amps. This happen to me once. Three amps running, the small amp was working but the 2000 watt and the 2000 watt mono light kept turning on red. After awhile i decided to test them one more time, this time with my car engine running and all of them came on.


    so try and see what happens.


    Peace




  3. #3
    omnipseudo's Avatar
    omnipseudo is offline .4Wheelin Sound Addict

    Threadstarter


    Join Date
    Apr 2004
    Location
    Vail, Colorado
    Age
    28
    Posts
    50
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)

    Re: Installing 2nd Amp To Speakers : Help Please

    thanks for the reply, but my Boss amp works fine, its the pioneer that im having the problems with. but ya you are right, boss has red and green lights, u know anything about the pioneers though?

    concerning power, thats highly possible as this is only a Jeep wrangler, ill try turning the tj on and see what happens. thanks again for the reply.



    2000 Jeep Wrangler Sport
    Tweets : In progress
    Speakers : 2 Alpine 4x6 SPS 2-Way and 2 Boston 5.25" RallyX
    Head Unit : Sony CDX-F7005X
    Amp : Boss 700w 2chan, 2ohm stable (Lookin for a new one)
    Subs : 2 10" Kicker Comp VRs
    Box : Sealed Custom QLogic

  4. #4
    johnecon2001's Avatar
    johnecon2001 is offline SSA/ROE Super-Møderator



    Join Date
    Aug 2004
    Location
    Phoenix, AZ
    Age
    31
    Posts
    5,137
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)

    Re: Installing 2nd Amp To Speakers : Help Please

    pioneer just has red. Just check all the connections again, and then hook an extra (if you have one) amp to the same speakers to see if the original is blown.




    Don't PM me, I'm not here. Find me on SSA or ROE
    No, I won't re-upload the Big3 pictures. Don't ask.

Closed Thread

Similar Threads

  1. Installing 2 1-Farad Caps to MMATS Amp
    By james33440 in forum Wiring, Electrical and Installation Help
    Replies: 12
    Last Post: 10-17-2002, 07:33 AM
  2. Installing 2 1-Farad Capacitors with MMATS Amp
    By james33440 in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 10-16-2002, 03:28 AM
  3. installing the amp kit tomorrow!
    By saltyjesus in forum Subwoofers
    Replies: 3
    Last Post: 09-03-2002, 12:37 AM
  4. 4 speakers on 2-channel amp
    By marcopolo in forum Subwoofers
    Replies: 6
    Last Post: 07-02-2002, 06:35 PM
  5. Factory speakers with amp?
    By Nolesman in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 02-26-2002, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum