+ Reply to Thread
Results 1 to 12 of 12

Reload Thread: Cobalt alt only charges sometimes....

  1. #1
    Join Date
    Jan 2018
    Location
    Beaver Dam, WI
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Cobalt alt only charges sometimes....

    I have a 2006 cobalt with the 2.2 ecotec, stock alt, but the vehicle only charges sometimes. Voltage will fluctuate between 12.4 and sometimes up to 15.2 while the engine is running (normally when charging it stays around itís regulated 14.4-14.6). Not rapidly, just sometimes itís charging then itís like a switch is flipped and then itís not then back to charging a while later and so on. Very frustrating because when itís charging it keeps good voltage (13.7+) full tilt but when it stops charging Iím dipping to like 12.0-12.2. Question is, is this a fuel economy feature or a fault somewhere? It could be a faulty alt because Iím pretty sure itís the original with 251k on it but Iíd think if the alt was bad it would just not work at all, not sometimes work sometimes not. If this is some stupid feature that the car computer is controlling when charging occurs how do I bypass that??







  2. #2
    BOOMINGRANDPA's Avatar
    BOOMINGRANDPA is offline CHEAP A/F



    Join Date
    Jan 2017
    Location
    NC
    Posts
    6,774
    Post Thanks / Like
    Images
    17
    Mentioned
    30 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2710 Post(s)

    Re: Cobalt alt only charges sometimes....

    wife had alero same motor never had problems but no system either.. go to advance ask them to do load test on alt/batt.. maybe alt just needs replaced maybe belt or pulley tensioner.. u may need alt or just a agm batt and big 3 wires under hood..



    KENWOOD X301 HU, PRECISION POWER Phantom 1000, FU 750 12, 2.1cfad ported, soundqubed 6.5" coax/doors, hp & lp xover on hu, AGM starting batt...
    Quote Originally Posted by Boomin_tahoe View Post
    2 ohms rule

  3. #3
    dragon.breath's Avatar
    dragon.breath is offline Senior VIP Member



    Join Date
    Nov 2007
    Location
    Al
    Posts
    463
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    109 Post(s)

    Re: Cobalt alt only charges sometimes....

    You have a pcm controlled alternator. The voltage you are describing is normal. Depending on your exact vehicle, you may be able to get a bypass module to fix your problem. Or it may be as simple as unplugging the voltage sensor wire at the battery.

    GM Modules



    digital designs 9512h with cf cap
    sundown saz 3000d at 2 ohms
    meca legal 141.3 db on the headrest with a 34hz tuned daily box

  4. #4
    Boomin_tahoe's Avatar
    Boomin_tahoe is offline Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    14,539
    Post Thanks / Like
    Images
    2
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    6181 Post(s)

    Re: Cobalt alt only charges sometimes....

    I just recently fixed this issue on my Tahoe by replacing the serpintine belt. Just one possibility for ya.



    97 4 dr. Tahoe
    Interstate battery
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps (New amps coming soon)
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

  5. #5
    familyguy9877's Avatar
    familyguy9877 is offline Member

    Threadstarter


    Join Date
    Jan 2018
    Location
    Beaver Dam, WI
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Re: Cobalt alt only charges sometimes....

    Quote Originally Posted by dragon.breath View Post
    You have a pcm controlled alternator. The voltage you are describing is normal. Depending on your exact vehicle, you may be able to get a bypass module to fix your problem. Or it may be as simple as unplugging the voltage sensor wire at the battery.

    GM Modules
    That website says the PCM controlled alts started after 2006 (the year of my cobalt) from looking at pictures it would appear my car should have the 4 pin plug. I didnít have time to take the intake out and look for sure though. I have only two agm batts in the vehicle already.




  6. #6
    BOOMINGRANDPA's Avatar
    BOOMINGRANDPA is offline CHEAP A/F



    Join Date
    Jan 2017
    Location
    NC
    Posts
    6,774
    Post Thanks / Like
    Images
    17
    Mentioned
    30 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2710 Post(s)

    Re: Cobalt alt only charges sometimes....

    replace belt check pulleys and get load test done if it test weak replace alt or batt



    KENWOOD X301 HU, PRECISION POWER Phantom 1000, FU 750 12, 2.1cfad ported, soundqubed 6.5" coax/doors, hp & lp xover on hu, AGM starting batt...
    Quote Originally Posted by Boomin_tahoe View Post
    2 ohms rule

  7. #7
    wew lad's Avatar
    wew lad is offline wew lad inc



    Join Date
    Mar 2015
    Location
    Des Moines, IA
    Posts
    5,399
    Post Thanks / Like
    Mentioned
    50 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2892 Post(s)

    Re: Cobalt alt only charges sometimes....

    if the voltage regulator is going bad, depending on the alt, they do act that way. when you rev the motor it's enough to self excite it and thats why it is more of an issue at idle for you

    verify it's not PCM controlled first, before anything

    also try posting on your vehicle specific forum



    Quote Originally Posted by JohnKuthe View Post
    I AM The Future of personal transportation, NOW!!
    Quote Originally Posted by Loudz View Post
    Pretty sure everyone on this site hates you (@JohnKuthe) more then me and that's very hard to accomplish.

  8. #8
    los33's Avatar
    los33 is offline Car Audio G



    Join Date
    Apr 2014
    Location
    Houston, TX
    Posts
    3,526
    Post Thanks / Like
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2251 Post(s)

    Re: Cobalt alt only charges sometimes....

    Your vehicle is pcm controlled and has a battery temp sensor.

    The ecotec crap in the pcm causes the alt to shutdown during stops and idling when not needed and also will stop charging as much at highway speeds.

    You need an external regulator to fix the issue.

    Sent from my SM-N950U using Tapatalk




  9. #9
    familyguy9877's Avatar
    familyguy9877 is offline Member

    Threadstarter


    Join Date
    Jan 2018
    Location
    Beaver Dam, WI
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Re: Cobalt alt only charges sometimes....

    Quote Originally Posted by wew lad View Post
    if the voltage regulator is going bad, depending on the alt, they do act that way. when you rev the motor it's enough to self excite it and thats why it is more of an issue at idle for you

    verify it's not PCM controlled first, before anything

    also try posting on your vehicle specific forum
    It doesn’t charge half the time even when I’m revving to 3k rpm. It’s like an on off switch




  10. #10
    familyguy9877's Avatar
    familyguy9877 is offline Member

    Threadstarter


    Join Date
    Jan 2018
    Location
    Beaver Dam, WI
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Re: Cobalt alt only charges sometimes....

    Quote Originally Posted by los33 View Post
    Your vehicle is pcm controlled and has a battery temp sensor.

    The ecotec crap in the pcm causes the alt to shutdown during stops and idling when not needed and also will stop charging as much at highway speeds.

    You need an external regulator to fix the issue.

    Sent from my SM-N950U using Tapatalk
    Are there any good external reg you would recommend??




  11. #11
    familyguy9877's Avatar
    familyguy9877 is offline Member

    Threadstarter


    Join Date
    Jan 2018
    Location
    Beaver Dam, WI
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Re: Cobalt alt only charges sometimes....

    Iíll try to get a load test done tomorrow




  12. #12
    los33's Avatar
    los33 is offline Car Audio G



    Join Date
    Apr 2014
    Location
    Houston, TX
    Posts
    3,526
    Post Thanks / Like
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2251 Post(s)

    Re: Cobalt alt only charges sometimes....

    Quote Originally Posted by familyguy9877 View Post
    Are there any good external reg you would recommend??
    Quote Originally Posted by familyguy9877 View Post
    Iíll try to get a load test done tomorrow
    Like your saying do all the basic checks like getting your battery tested and alternator tested for working condition.

    If all is good then move on to the normal bluebox external regulator you find in car audio applications.

    The mainstream use of it is in limosines, theres only one available aside from all the chinese knockoffs.

    Also alternator companies like mechman,singer,ces, etc.. all provide a pcm bypass solution for gm vehicles now.

    Sent from my SM-N950U using Tapatalk




+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum