+ Reply to Thread
Results 1 to 6 of 6

Reload Thread: Which amp to use

  1. #1
    Cwrig's Avatar
    Cwrig is offline Junior Member



    Join Date
    May 2017
    Location
    Charlotte, NC
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Which amp to use

    Okay, so it's been at least 10 years since I've done an install, and I've only ever installed SVC subs. I'm not looking for earth shattering bass, just a well rounded sound in this truck I just bought, so with limited space, I bought an 8" DVC 4 Ohm shallow mount RF woofer with a 150W RMS (300W max). I have two old amps, and I'm not sure which will be the best option, since I can't deliver a 4 Ohm load to the amp.

    One amp is an ancient RF Punch 2 channel 50W x2 RMS at 2 Ohm. I had this one hooked up to the new sub, wired parallel to deliver 2 Ohms, and it sounded great, but it ran incredibly hot within just a few minutes. I believe this is because I had it bridged. The second amp is an old Alpine mono 200W RMS at 4 Ohm/350W at 2 Ohm.

    So basically my question is this: would I be better off A) sticking with the parallel wiring on the RF amp, letting it run hot, B) not bridging the RF amp, or C) switching my wiring to series and using the Alpine amp at 8 Ohms? I'm worried that the RF would underpower the sub, but I'm also concerned that using the Alpine at 2 Ohms will overpower and blow the sub (it blew an old MB Quart sub I had with that setup yesterday, hence the new RF sub). Or if anyone has any other suggestions, I'm open. Any insight is appreciated.







  2. #2
    garychoffmann's Avatar
    garychoffmann is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    1,886
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    500 Post(s)

    Re: Which amp to use

    Wire to 2 ohms on the alpine and set it to deliver a clean 150-200 watts. Multiple ways to do this but youtube setting gains with a dmm




  3. #3
    BOOMINGRANDPA's Avatar
    BOOMINGRANDPA is offline NOT TO OLD TO BASS



    Join Date
    Jan 2017
    Location
    NC
    Posts
    3,935
    Post Thanks / Like
    Images
    17
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1599 Post(s)

    Re: Which amp to use

    whats up nc guy.. yeah u can try the alpine see how it sounds.. am I confused u said sub is d4 so wire to 2 ohm and hook the alpine to it for 350rms and set gain low (my sub rated at 600 I'm running 938 others here run 1500rms to 500rms subs, set gain low no need for bass boost).. anything less that that ain't worth the trouble anyway.. and if that's not enough power for u I have a autotek 1600 (500rms @2ohms) 4 months old (just got bigger amp 3 days ago) i'll sell u that for $50 if u ever drive close to Sanford, if u want to run 2 subs or get rid of that and get a 12..



    KENWOOD X301 HU, PRECISION POWER Phantom 1000, FU 750 12, custom 2.11 cf ad ported tuned @ 36hz 30.375 port area, soundqubed 6.5" coax xover (hu), AGM starting batt... FU 750 destroying my spoiler https://www.youtube.com/watch?v=joeeCIZJpUs pioneer 3003 videos https://www.youtube.com/watch?v=rTcgVGvuFX8 https://www.youtube.com/watch?v=WI4yGDqN27g

  4. #4
    Cwrig's Avatar
    Cwrig is offline Junior Member

    Threadstarter


    Join Date
    May 2017
    Location
    Charlotte, NC
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Which amp to use

    Thank you both for your suggestions. I'll leave the sub wired at 2 Ohms and set the gain to provide 150W until it's broken in.

    Quote Originally Posted by BOOMINGRANDPA View Post
    whats up nc guy.. yeah u can try the alpine see how it sounds.. am I confused u said sub is d4 so wire to 2 ohm and hook the alpine to it for 350rms and set gain low (my sub rated at 600 I'm running 938 others here run 1500rms to 500rms subs, set gain low no need for bass boost).. anything less that that ain't worth the trouble anyway.. and if that's not enough power for u I have a autotek 1600 (500rms @2ohms) 4 months old (just got bigger amp 3 days ago) i'll sell u that for $50 if u ever drive close to Sanford, if u want to run 2 subs or get rid of that and get a 12..
    I appreciate the offer. I actually have 2 Kenwood 12"s laying around from a previous install, and a 1000W 1 Ohm stable JL amp. I just don't need that much boom or want to occupy that much space under the back seats. Although, now that I've been working on this, my wife has decided she "needs" the 2 12"s in her car....




  5. #5
    Stellar1024's Avatar
    Stellar1024 is offline Junior Member



    Join Date
    Nov 2012
    Location
    Dallas
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Which amp to use

    Keep in mind, if an amp is 2 ohm stable minimum... when you bridge it, it will be 4 ohm stable minimum. That likely explains why the fosgate over heated. Also, those old amps are underrated so the fosgate is probably more powerful than it states... I'd first try running the Fosgate not bridged.. if it doesn't sound good, try the Alpine. If it still gets hot, try wiring series.. basically trial and error..




  6. #6
    BOOMINGRANDPA's Avatar
    BOOMINGRANDPA is offline NOT TO OLD TO BASS



    Join Date
    Jan 2017
    Location
    NC
    Posts
    3,935
    Post Thanks / Like
    Images
    17
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1599 Post(s)

    Re: Which amp to use

    Quote Originally Posted by Cwrig View Post
    Thank you both for your suggestions. I'll leave the sub wired at 2 Ohms and set the gain to provide 150W until it's broken in.



    I appreciate the offer. I actually have 2 Kenwood 12"s laying around from a previous install, and a 1000W 1 Ohm stable JL amp. I just don't need that much boom or want to occupy that much space under the back seats. Although, now that I've been working on this, my wife has decided she "needs" the 2 12"s in her car....
    u and i have very different wives., mine told me this morning if i put my sub and old amp in her car she'd kill me., i was looking for excuse to get new sub lol..



    KENWOOD X301 HU, PRECISION POWER Phantom 1000, FU 750 12, custom 2.11 cf ad ported tuned @ 36hz 30.375 port area, soundqubed 6.5" coax xover (hu), AGM starting batt... FU 750 destroying my spoiler https://www.youtube.com/watch?v=joeeCIZJpUs pioneer 3003 videos https://www.youtube.com/watch?v=rTcgVGvuFX8 https://www.youtube.com/watch?v=WI4yGDqN27g

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum