+ Reply to Thread
Results 1 to 4 of 4

Reload Thread: first time installing sub system

  1. #1
    2000silverado's Avatar
    2000silverado is offline Junior Member



    Join Date
    Jul 2014
    Location
    Leander,TX
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    first time installing sub system

    i just got 2 12'' TREO dvc 2 ohm subs from a friend he recommended getting a power acoustik 6000d amp and so that is what i got. i have started to install everything and i know that the speaker is fine(only installing one for right now) and i am getting power to the amp but nothing from the sub. i am using the factory head unit in my 2000 silverado so i bought a rca line out adapter and got it all wired up but i am still not getting anything from the sub at all







  2. #2
    Jeffdachef's Avatar
    Jeffdachef is offline 160 db farts n sharts



    Join Date
    Feb 2013
    Location
    Orange County, CA
    Posts
    3,481
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1264 Post(s)

    Re: first time installing sub system

    Quote Originally Posted by 2000silverado View Post
    i just got 2 12'' TREO dvc 2 ohm subs from a friend he recommended getting a power acoustik 6000d amp and so that is what i got. i have started to install everything and i know that the speaker is fine(only installing one for right now) and i am getting power to the amp but nothing from the sub. i am using the factory head unit in my 2000 silverado so i bought a rca line out adapter and got it all wired up but i am still not getting anything from the sub at all
    check your sub's wiring and how its wired to the amp.



    Clip city b1tch, clip clip city b1tch. 10's, 12's, 15's, goin up in flames b1tch.
    2009 Sienna 3.5L Subs : C2 threatcon 15s. Sub amp: hifonics brx 2400.1D x 2
    Headunit: Pioneer 80PRS bought used from vertex audio Mids/Highs amp: PPI Phantom 900.4 - bought from dragnix
    Front stage: 3 way active front stage with Massive Audio CKX tweets, alpine type R 6x9 midbass in doors + DB drive pro audio 6.5 in the kick.
    320 amp Singer alt almost installed. 0 gauge Audio technix ofc all around, 2 group 31 agms in the back.

  3. #3
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    195 Post(s)

    Re: first time installing sub system

    balance the radio left to right and see if you get output. Possible the loc is out of phase.




  4. #4
    NoLoud4U's Avatar
    NoLoud4U is online now High Output SQ



    Join Date
    Apr 2011
    Location
    Va Beach, Va
    Age
    34
    Posts
    8,656
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2816 Post(s)

    Re: first time installing sub system

    Quote Originally Posted by 2000silverado View Post
    i just got 2 12'' TREO dvc 2 ohm subs from a friend he recommended getting a power acoustik 6000d amp and so that is what i got. i have started to install everything and i know that the speaker is fine(only installing one for right now) and i am getting power to the amp but nothing from the sub. i am using the factory head unit in my 2000 silverado so i bought a rca line out adapter and got it all wired up but i am still not getting anything from the sub at all
    Your friend screwed you. Those amps no good



    2014 Ford Fusion
    All stock everything.

+ Reply to Thread

Similar Threads

  1. First time install.Component system.
    By Camo in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 07-21-2012, 06:54 PM
  2. Need Help: First-time installing head unit and damaged some electrical systems
    By majinwu in forum Wiring, Electrical and Installation Help
    Replies: 13
    Last Post: 08-16-2008, 02:23 AM
  3. First time buying subs...........
    By Magg103 in forum Subwoofers
    Replies: 12
    Last Post: 04-14-2008, 10:39 AM
  4. First Time Installing Head Unit!! Help
    By jameisonstyle in forum Head Units
    Replies: 4
    Last Post: 08-03-2007, 06:33 PM
  5. First time installing, retarded problem...help!!!
    By peepr in forum Wiring, Electrical and Installation Help
    Replies: 38
    Last Post: 11-01-2005, 02:52 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum