+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 17 of 17

Reload Thread: Amp gets power but sub doesnt work, help me

  1. #16
    Monsoon26's Avatar
    Monsoon26 is offline Junior Member

    Threadstarter


    Join Date
    Jul 2014
    Location
    Sartell, MN
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp gets power but sub doesnt work, help me

    Took a video of my settings on my HU and Amp. https://www.youtube.com/watch?v=cY52...fdk8x18dQ&hd=1

    So do i need a new sub? or is it something i can fix? I dont think its blown since it still produces all the bass just the lower stuff sounds like crap.







  2. #17
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Amp gets power but sub doesnt work, help me

    meter the sub and see what the ohms are resting at. Also gently depress the sub and see if you feel anything scratchy.




+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Amp is getting power but sub is not hitting?
    By matts_pyro in forum General Discussion
    Replies: 2
    Last Post: 08-23-2013, 12:00 AM
  2. Amp gets power, but when grounded it doesnt?
    By hatkoff in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 09-10-2006, 03:44 PM
  3. Amps getting power, but no output... What blew?
    By Beermanpb14 in forum Amplifiers
    Replies: 10
    Last Post: 05-14-2006, 10:23 PM
  4. amp gets power but wont function?
    By lAciDl in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 09-11-2003, 04:44 PM
  5. Amp get power, but doenst work
    By <MyCarsNamedAlice> in forum Amplifiers
    Replies: 4
    Last Post: 12-31-2001, 01:13 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum