+ Reply to Thread
Results 1 to 3 of 3

Reload Thread: Amp questions

  1. #1
    Travisiwb's Avatar
    Travisiwb is offline Junior Member



    Join Date
    Jun 2014
    Location
    Weirsdale,fl
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon32 Amp questions

    I have a kicker cx1200.1 powering two sundown audio e-10's and the amp goes into protect and the settings aren't even set high the subs are four ohm wondering if I should drop them to 2 or 1 ohm because the amp should push them fine?







  2. #2
    Join Date
    Jan 2009
    Location
    Buffalo, NY
    Posts
    105
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    12 Post(s)

    Re: Amp questions

    Figure out why it's going in to protect before lowering impedance. I would think that asking the amp to flow out more power isn't going to help it stay out of protect. I'm of the thought that you should figure what's wrong now before you change something.



    Functional Stupidity

  3. #3
    fly_marlin's Avatar
    fly_marlin is offline Senior VIP Member



    Join Date
    Apr 2014
    Location
    United States
    Posts
    398
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    132 Post(s)

    Re: Amp questions

    The subs you have - are they dual 2ohm or dual 4ohm voice coils? If it's dual 4 and you have them wired down to 1ohm net impedance, that would make the amp go into protect mode. That amp is only stable down to 2ohms. Check the specs for your subs, I bet that you have them wired down to 1ohm.




+ Reply to Thread

Similar Threads

  1. Amp question
    By adam182002 in forum Amplifiers
    Replies: 8
    Last Post: 02-09-2002, 10:34 PM
  2. Amp question
    By Adam182002 in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 02-08-2002, 05:32 PM
  3. Amp Question
    By RangerMan in forum Subwoofers
    Replies: 2
    Last Post: 02-03-2002, 03:16 PM
  4. Xplod Amp Question
    By Unregistered in forum Amplifiers
    Replies: 2
    Last Post: 01-26-2002, 10:39 PM
  5. Amp question
    By Albokid in forum Amplifiers
    Replies: 1
    Last Post: 01-23-2002, 01:41 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum