+ Reply to Thread
Results 1 to 4 of 4

Reload Thread: Amp cutting out on bass hits, but amp not in protection mode

  1. #1
    atownmack's Avatar
    atownmack is offline Member



    Join Date
    Mar 2013
    Location
    auburn, al
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp cutting out on bass hits, but amp not in protection mode

    I just swapped amps from a Power Acoustik BAMF 5500 to a JL Audio 500/1. BAMF was running fine, but with the JL Audio whenever the bass hits or I turn the volume up, the sub wont play. The amp is cool to the touch, (not even slightly warm.) The sub is an elipse 8122 dvc 4ohm wired to 2 ohms. Does anyone have any ideas that may help?







  2. #2
    VWGolfMKVI's Avatar
    VWGolfMKVI is online now StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Posts
    1,358
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp cutting out on bass hits, but amp not in protection mode

    Bad ground. Re do the amps ground and see if it continues.




  3. #3
    atownmack's Avatar
    atownmack is offline Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    auburn, al
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp cutting out on bass hits, but amp not in protection mode

    Quote Originally Posted by VWGolfMKVI View Post
    Bad ground. Re do the amps ground and see if it continues.
    Ill try that. I use a 0 gauge power and ground and split that to a 4 gauge wires to power a 4 channel amp and a mono amp. They both share the same ground and have had no issues with this set up for over 3 years. The 4 channel is running fine, but the mono amps are giving trouble with big bass hits.




  4. #4
    VWGolfMKVI's Avatar
    VWGolfMKVI is online now StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Posts
    1,358
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp cutting out on bass hits, but amp not in protection mode

    The Power Acoustik was not requiring the amperage the JL is. So as it pulls amps its not getting the adequate ground. I had a friend with a Soundstream Amp I installed and scratched my head for an hour trying to figure out what I did wrong. It would power on, play at low volumes, turn up the volume and it would shut down. I redid the ground and was golden. Its the easiest to check and replace, so start there.




+ Reply to Thread

Similar Threads

  1. HELP!! amp cutting out when bass hits????
    By luvbass in forum Wiring, Electrical and Installation Help
    Replies: 17
    Last Post: 01-17-2011, 03:49 PM
  2. amp cuts out when bass actually hits
    By a_steezy in forum General Discussion
    Replies: 36
    Last Post: 08-04-2008, 02:31 PM
  3. Amp cuts out when sub hits hard
    By taosd in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 06-26-2008, 06:38 PM
  4. Amp cut out on me and has me concerned
    By Intercooler in forum Amplifiers
    Replies: 1
    Last Post: 01-24-2006, 01:53 PM
  5. amp cuts out when bass hits
    By furiousedge2 in forum Amplifiers
    Replies: 17
    Last Post: 07-10-2003, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum