+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20

Reload Thread: Amp goes into protection mode when i hook speakers up. Please help driving me crazy

  1. #1
    Nasgotti's Avatar
    Nasgotti is offline Junior Member



    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Amp goes into protection mode when i hook speakers up. Please help driving me crazy

    OK so I had a little 400 watt crappy duel amp hooked up to 2 10 inch mtxs but then i bought a 12 inch kicker comp and a Audiobahn A8000t its a 1600 watt mono maxx amp. Ok now here is the issue i have all the wiring done right in my bmw and it was running my old amp and subs now when i hook up the audiobahn amp the amp turns on and its fine but as soon as i hook the speakers up it goes into protection mode and its driving me crazy can someone please help. I live in vermont and there isnt crap for shops around here so i have to figure this out myself im very good with directions and stuff i would be very grateful







  2. #2
    Slobalt's Avatar
    Slobalt is offline CarAudio.com Elite



    Join Date
    Aug 2013
    Location
    East Coast
    Posts
    567
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    When you say you hook the speakers up you mean the subs to the amp?




  3. #3
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    995
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    too low of an ohm load for the amp. check the final load at the amp with a meter and see what you get. How many speakers are you connecting to the amp? What specific models of subs?




  4. #4
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    Yes when i hook the subs to the amp it goes to protection mode slobalt. CrossoverOre I will go out to my car now and take sub out and open box to see Im only connecting one a sub to the amp its a mono amp the subs a kicker 12 inch but model number ill go check now brb thanks for helping guys




  5. #5
    gtstangrunner's Avatar
    gtstangrunner is offline Junior Member



    Join Date
    May 2013
    Location
    Phoenix, AZ
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    I would agree with CrossoverOre. Also make sure your positive and negative speaker wires are not somehow getting crossed. Some amps have a Protection circuit in them that detects when a short occurs in the speakers. The preamp section is likely ok if it doesn't go into protect with the RCA's only. Certainly check your OHM load going to the amp like Crossover said.




  6. #6
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    ok im going to take speaker out of box now and take pictures for you and then let me know how i should re wire it ill take picture of my amp also. i just didnt understand why it works on my small amp but now the bigger amp




  7. #7
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    the speaker says kicker comp pvr in the back duel voice coil 12v 2ohm




  8. #8
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    995
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    It looks like that amp is 2 ohm stable if the sub is a dual 2ohm vc and you have it wired in parallel then that is your problem.




  9. #9
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    Here is the pictures i just took please let me know how i should re wire the sub thanks how do i upload the pic lol




  10. #10
    Beatin''s Avatar
    Beatin' is online now CarAudio.com Elite



    Join Date
    Nov 2012
    Location
    MI
    Posts
    983
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    DVC 2ohm paralleled will create a 1 ohm load. Amp is unable to handle 1 ohm load so it shuts off.



    All day I'm clippin'
    voltage be dippin'
    I don't give a damn,
    cause my trunk always hittin'!

    creating a proper sound wave. Step one, turn it up until clipping. Step two, done.

  11. #11
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    should i rewire it to 4 ohm take one positive and one negative together then wire the other pos and neg to amp?[COLOR="Silver"]





  12. #12
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra



    ---------- Post added at 01:39 PM ---------- Previous post was at 01:39 PM ----------

    i cant figure out how to get apicture on here here is the link of the picture https://drive.google.com/file/d/0BzP...it?usp=sharing

    ---------- Post added at 01:40 PM ---------- Previous post was at 01:39 PM ----------

    thanks let me know how i should wire




  13. #13
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,261
    Post Thanks / Like
    Mentioned
    43 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    Quote Originally Posted by Nasgotti View Post


    ---------- Post added at 01:39 PM ---------- Previous post was at 01:39 PM ----------

    i cant figure out how to get apicture on here here is the link of the picture https://drive.google.com/file/d/0BzP...it?usp=sharing

    ---------- Post added at 01:40 PM ---------- Previous post was at 01:39 PM ----------

    thanks let me know how i should wire
    Wire it to 4ohms right now u have it wired at 1 ohm and the amp isnt 1ohm stable so its going into protect

    ---------- Post added at 01:45 PM ---------- Previous post was at 01:45 PM ----------

    Subwoofer Wiring Diagrams




  14. #14
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    ok i rewired the sub to 4 ohm and its still fricking going to protection mode when i hook the subs up i dont understand




  15. #15
    Nasgotti's Avatar
    Nasgotti is offline Junior Member

    Threadstarter


    Join Date
    Mar 2014
    Location
    Vermont
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp goes into protection mode when i hook speakers up. Please help driving me cra

    what else could it be could it be something with the amp?




+ Reply to Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 11
    Last Post: 12-13-2013, 10:51 AM
  2. amp goes into protect mode after i turn it up
    By Squirrel18 in forum Amplifiers
    Replies: 4
    Last Post: 04-03-2010, 01:14 AM
  3. Help; amp goes into protect mode when imput @ 50%
    By SocialStealth in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 04-07-2009, 06:13 PM
  4. Help; amp goes into protect mode when input @ 50%
    By SocialStealth in forum Amplifiers
    Replies: 14
    Last Post: 04-07-2009, 04:33 PM
  5. amp goes into protection mode when played to loud
    By xbatxattackx in forum Amplifiers
    Replies: 25
    Last Post: 05-19-2008, 05:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum