Closed Thread
Results 1 to 8 of 8

Reload Thread: popping sound from subs

  1. #1
    pico's Avatar
    pico is offline Member



    Join Date
    May 2004
    Location
    Modesto, CA
    Posts
    147
    Post Thanks / Like
    Mentioned
    0 Post(s)

    popping sound from subs

    i have a 75 coupe deville with 2 15" subs connected to a pyramid amp. everything worked fine until a few days ago i was driving home and my subs cut off. i turned off my deck and turned it back on and the subs were popping. the system was working for a few months with no problems and it happened out of nowhere. i checked all the connections and everything is good. does anyone have any ideas on what i can do to fix this?







  2. #2
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,418
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: popping sound from subs

    Now you know why everybody here hates Pyramid amps. Sorry buddy.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  3. #3
    jnminden's Avatar
    jnminden is offline Junior Member



    Join Date
    May 2004
    Location
    Michigan
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    What do you mean by popping? Like constant popping, that's all they would do, or some popping with some bass?




  4. #4
    pico's Avatar
    pico is offline Member

    Threadstarter


    Join Date
    May 2004
    Location
    Modesto, CA
    Posts
    147
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    its a constant popping and thats all. i tried to hook other speakers to it and it does the same thing.




  5. #5
    jimmyslide's Avatar
    jimmyslide is offline Let me get you a spoon...



    Join Date
    Mar 2002
    Location
    Lethbridge,AB
    Age
    32
    Posts
    993
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    Amp is flucked!!!

    You are trying to get way too much out of the pyramid amp. You are likely expecting it to make the wattage it claims and it isn't, so you turned up the gains and the amp is sending clipped signals to the subs.

    Bad Amp...


    Shawn...



    My lug nuts require more torque then your Honda makes

    Owner/Founder of Obnoxious Distributions
    Canadian Distributor/Rep for Atomic Loudspeakers
    Newest member of TEAM ATOMIC
    1/2 of TEAM TUNED

    For Sale: Kicker KX600.1, Memphis st16-200

  6. #6
    negativezeroz's Avatar
    negativezeroz is offline Nothing Is Promised



    Join Date
    May 2004
    Location
    -salad fingers-
    Age
    26
    Posts
    4,900
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    Seriously,

    WHY THE H*** ARE YOU USING PYRAMID?????????!!!!!!!!!!

    end of my statement




  7. #7
    pico's Avatar
    pico is offline Member

    Threadstarter


    Join Date
    May 2004
    Location
    Modesto, CA
    Posts
    147
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    i was using pyramid because it was all i could afford when i bought it.




  8. #8
    infinity1412's Avatar
    infinity1412 is offline Senior VIP Member



    Join Date
    Feb 2004
    Location
    ocala fl
    Age
    28
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: popping sound from subs

    i would recomend u get a new amp, if ur still on a budget, profiles arent bad amps for the price IMO

    mike



    98 Blazer 4x4

    HU: Crappy Sony
    Speakers: Stock
    Sub amp: ****** Soundstorm 500.2
    Subs: 2 JL W0 15s
    Box: 4.8 Cubes sealed

    hit 144.0 on AC mic with this setup that only costed 100 bucks, not bad

Closed Thread

Similar Threads

  1. Whining/Whistling Sound coming from speakers?
    By qwkracer in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 04-10-2004, 03:34 PM
  2. is this possible, 3 subs, 2 amps, please read.
    By dropt72shortbed in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 02-10-2004, 07:39 AM
  3. ?? have two amps need subs please help
    By rswroughneck in forum Subwoofers
    Replies: 2
    Last Post: 02-08-2004, 03:11 PM
  4. Subs should like theres an echo or a hallow sound.
    By jlaudiow6 in forum Subwoofers
    Replies: 4
    Last Post: 12-11-2003, 04:01 AM
  5. Newbie needs info on subs
    By arnjolt in forum Subwoofers
    Replies: 20
    Last Post: 10-03-2003, 04:44 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum