+ Reply to Thread
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 39 of 39

Reload Thread: Subs aren't hitting like they should... Please Help

  1. #31
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    And sub at 0






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html





  2. #32
    SplAffair's Avatar
    SplAffair is offline I lol'd



    Join Date
    Mar 2009
    Location
    Knocksville, TN
    Age
    23
    Posts
    2,116
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    I too thought on my alpine you had to set the sub +15 to get full pre amp voltage. This isn't right?



    Quote Originally Posted by predxen View Post
    Its not as loud as it should be, you stop hearing it about a block away. you should be able to hear it a quarter mile away.
    .
    Quote Originally Posted by hispls View Post
    You need to keep the smoke INSIDE the amplifier. Once you've allowed all the happy smoke to escape the amp will stop working.
    BOYCOTT SKAR AUDIO! SHADY BUSINESS PRACTICES SHOULD NEVER BE ENCOURAGED!

  3. #33
    Chriszle's Avatar
    Chriszle is offline CarAudio.com Elite



    Join Date
    Jan 2011
    Location
    SD
    Posts
    1,718
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    You can set the gain on the amp with whatever sub setting you want. It really doesn't make a difference (as long as the signal being sent to the amp is not clipped). You have more range if you set the gain with the subwoofer volume up, as you can attenuate it down as much as you need to. For instance my kenwood clips at 33/35 with
    +13 subwoofer setting. If you bump it to +15 (max) it clips at 29/35. I can choose to set the gain at either point, knowing exactly where I cannot go past either way.

    I should say this is also h/u dependent. If your subwoofer volume control boosts certain frequencies, it is best left at 0.




  4. #34
    heimsothe's Avatar
    heimsothe is offline Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    Portland, OR
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    Going to try to fix things up today after classes. Couldn't get around to it yesterday with all the midterms and lack of light in the after noon.




  5. #35
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    They make these things called flashlights now....






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


  6. Likes heimsothe liked this post
  7. #36
    heimsothe's Avatar
    heimsothe is offline Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    Portland, OR
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    Quote Originally Posted by nismos14 View Post
    They make these things called flashlights now....
    Chalk it up to a count of laziness then




  8. #37
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    Ain't no cure for that.






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


  9. #38
    heimsothe's Avatar
    heimsothe is offline Member

    Threadstarter


    Join Date
    Dec 2013
    Location
    Portland, OR
    Posts
    66
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    You mean they don't make a flashlight for that???




  10. #39
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Subs aren't hitting like they should... Please Help

    Nope, just an APP.






    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


+ Reply to Thread
Page 3 of 3 FirstFirst 1 2 3

Similar Threads

  1. Subs aren't hitting PLEASE HELP!!!
    By Justin braaapp in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 09-21-2013, 01:16 PM
  2. Replies: 7
    Last Post: 09-21-2013, 07:52 AM
  3. subs aren't hitting as hard as they should
    By snev in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 01-20-2012, 10:46 PM
  4. Replies: 17
    Last Post: 06-25-2010, 04:24 PM
  5. alpine type x's not hitting like they should...
    By snowcruizer713 in forum Subwoofers
    Replies: 26
    Last Post: 01-31-2010, 09:22 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum